Read the docs
TI-2026-26691 Aliases CVE-2026-34406

APTRS: Privilege Escalation via Mass Assignment of is_superuser in User Edit Endpoint

Priority HIGH 76CWE-915Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-915.

Summary

APTRS (Automated Penetration Testing Reporting System) is a Python and Django-based automated reporting tool designed for penetration testers and security organizations. Prior to version 2.0.1, the edit_user endpoint (POST /api/auth/edituser/<pk>) allows Any user who can reach that endpoint and submit crafted permission to escalate their own account (or any other account) to superuser by including "is_superuser": true in the request body. The root cause is that CustomUserSerializer explicitly includes is_superuser in its fields list but omits it from read_only_fields, making it a writable field. The edit_user view performs no additional validation to prevent non-superusers from modifying this field. Once is_superuser is set to true, gaining unrestricted access to all application functionality without requiring re-authentication. This issue has been patched in version 2.0.1.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00524 44th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed APTRS (APTRS): 2.0.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
APTRSAPTRSbefore 2.0.12.0.1Patch availableCNA
  • APTRS VendorAPTRS Affected before 2.0.1 Fixed in 2.0.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:aptrs:aptrs:*:*:*:*:*:python:*:*before 2.0.1VulnerableAPTRS
  • cpe:2.3:a:aptrs:aptrs:*:*:*:*:*:python:*:* Versions before 2.0.1 Vulnerable ·APTRS

Remediation

  • Fix · CNA APTRS (APTRS) Fixed in 2.0.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-34406
  2. 2026-10-25 EPSS moved to the below the 50th percentile

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences