Cross-site scripting in ci4-cms-erp ci4ms
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting, Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79 and CWE-269.
Summary
CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. Prior to 31.0.0.0, the application fails to properly sanitize user-controlled input when users update their profile name (e.g., full name / username). An attacker can inject a malicious JavaScript payload into their profile name, which is then stored server-side. This stored payload is later rendered unsafely in multiple application views without proper output encoding, leading to stored cross-site scripting (XSS). This vulnerability is fixed in 31.0.0.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ci4-cms-erp | ci4ms | before 31.0.0.0 | 31.0.0.0 | Patch available | CNA |
| — | ci4-cms-erp/ci4ms (Packagist) | before 31.0.0.0 | 31.0.0.0 | Patch available | GHSA-vr2g-rhm5-q4jr |
- ci4ms Vendorci4-cms-erp Affected before 31.0.0.0 Fixed in 31.0.0.0 Patch available CNA
- ci4-cms-erp/ci4ms (Packagist) Vendor— Affected before 31.0.0.0 Fixed in 31.0.0.0 Patch available GHSA-vr2g-rhm5-q4jr
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ci4-cms-erp:ci4ms:*:*:*:*:*:*:*:* | before 0.31.0.0 | Vulnerable | ci4-cms-erp |
- cpe:2.3:a:ci4-cms-erp:ci4ms:*:*:*:*:*:*:*:* Versions before 0.31.0.0 Vulnerable ·ci4-cms-erp
Remediation
- Fix · CNA ci4ms (ci4-cms-erp) Fixed in 31.0.0.0
- Fix · GHSA-vr2g-rhm5-q4jr ci4-cms-erp/ci4ms (Packagist) Fixed in 31.0.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-34989
- 2026-10-03 Alias added: GHSA-vr2g-rhm5-q4jr
References
More ci4-cms-erp Ci4ms vulnerabilities
- TI-2026-26819 Improper access control in ci4-cms-erp ci4ms CVSS 3.1HIGH 8.8
- TI-2026-28379 CI4MS has an .env CRLF Injection via Unvalidated `host` Parameter in Install Controller CVSS 3.1CRITICAL 9.8
- TI-2026-26820 Cross-site scripting in ci4-cms-erp ci4ms CVSS 3.1CRITICAL 10.0
- TI-2026-26818 CI4MS: Blogs Categories Full Account Takeover for All-Roles & Privilege-Escalation via Stored DOM XSS CVSS 3.1CRITICAL 10.0
- TI-2026-27238 Cross-site scripting in ci4-cms-erp ci4ms CVSS 3.1CRITICAL 9.0
- TI-2026-26821 Improper access control in ci4-cms-erp ci4ms CVSS 3.1HIGH 8.8
Sources
- CVE-2026-34989 · CVE Program
- CVE-2026-34989 · NVD
- FIRST EPSS
- GHSA-vr2g-rhm5-q4jr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences