Read the docs
TI-2026-27329 Aliases CVE-2026-35175GHSA-73jv-44c3-j5p2

Ajenti has an authorization bypass during custom package installation

Priority LOW 31CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Security bypass
Confidentiality · integrity · availability
Low · High · Low
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-862.

Summary

Ajenti is a Linux and BSD modular server admin panel. Prior to 2.2.15, an authenticated user (using the auth_users plugin authentication method) could install a custom package even if this user is not superuser. This vulnerability is fixed in 2.2.15.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00277 20th percentileScored 2026-11-07
Fix Fixed ajenti (ajenti): 2.2.15ajenti-panel (PyPI): 2.2.15

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ajentiajentibefore 2.2.152.2.15Patch availableCNA
—ajenti-panel (PyPI)before 2.2.152.2.15Patch availableGHSA-73jv-44c3-j5p2
  • ajenti Vendorajenti Affected before 2.2.15 Fixed in 2.2.15 Patch available CNA
  • ajenti-panel (PyPI) Vendor— Affected before 2.2.15 Fixed in 2.2.15 Patch available GHSA-73jv-44c3-j5p2

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ajenti:ajenti:*:*:*:*:*:*:*:*before 2.2.15Vulnerableajenti
  • cpe:2.3:a:ajenti:ajenti:*:*:*:*:*:*:*:* Versions before 2.2.15 Vulnerable ·ajenti

Remediation

  • Fix · CNA ajenti (ajenti) Fixed in 2.2.15
  • Fix · GHSA-73jv-44c3-j5p2 ajenti-panel (PyPI) Fixed in 2.2.15 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-35175
  2. 2026-10-03 Alias added: GHSA-73jv-44c3-j5p2

References

  • TI-2019-15206 ajenti API privileges management CVSS 3.1HIGH 8.8
  • TI-2026-22317 Ajenti has a potential Remote Code Execution CVSS 4.0HIGH 8.1
  • TI-2018-15737 Ajenti version version 2 contains a Cross ite Request Forgery (CSRF) vulnerability in the… CVSS 3.0HIGH 8.8
  • TI-2018-15779 Ajenti version 2 contains an Information Disclosure vulnerability in Line 176 of the code… CVSS 3.0HIGH 7.5
  • TI-2018-15736 Ajenti version version 2 contains a Input Validation vulnerability in ID string on… CVSS 3.0HIGH 7.5
  • TI-2018-15735 Ajenti version version 2 contains a Insecure Permissions vulnerability in Plugins… CVSS 3.0MEDIUM 6.5
See all 9 →

Sources