Glances IP Plugin has SSRF via public_api that leads to credential leakage
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
Glances is an open-source system cross-platform monitoring tool. Prior to version 4.5.4, a Server-Side Request Forgery (SSRF) vulnerability exists in the Glances IP plugin due to improper validation of the public_api configuration parameter. The value of public_api is used directly in outbound HTTP requests without any scheme restriction or hostname/IP validation. An attacker who can modify the Glances configuration can force the application to send requests to arbitrary internal or external endpoints. Additionally, when public_username and public_password are set, Glances automatically includes these credentials in the Authorization: Basic header, resulting in credential leakage to attacker-controlled servers. This vulnerability can be exploited to access internal network services, retrieve sensitive data from cloud metadata endpoints, and/or exfiltrate credentials via outbound HTTP requests. The issue arises because public_api is passed directly to the HTTP client (urlopen_auth) without validation, allowing unrestricted outbound connections and unintended disclosure of sensitive information. Version 4.5.4 contains a patch.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| nicolargo | glances | before 4.5.4 | 4.5.4 | Patch available | CNA |
| — | glances (PyPI) | before 4.5.4 | 4.5.4 | Patch available | GHSA-g5pq-48mj-jvw8 |
- glances Vendornicolargo Affected before 4.5.4 Fixed in 4.5.4 Patch available CNA
- glances (PyPI) Vendor— Affected before 4.5.4 Fixed in 4.5.4 Patch available GHSA-g5pq-48mj-jvw8
Remediation
- Fix · CNA glances (nicolargo) Fixed in 4.5.4
- Fix · GHSA-g5pq-48mj-jvw8 glances (PyPI) Fixed in 4.5.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-35587
- 2026-10-03 Alias added: GHSA-g5pq-48mj-jvw8
References
More nicolargo Glances vulnerabilities
- TI-2026-25142 Glances's Browser API Exposes Reusable Downstream Credentials via `/api/4/serverslist` CVSS 3.1CRITICAL 9.1
- TI-2026-25106 Glances exposes the REST API without authentication CVSS 4.0HIGH 8.7
- TI-2026-27083 Glances Vulnerable to Cross-Origin Information Disclosure via Unauthenticated REST API (/api/4) due to Permissive CORS CVSS 4.0HIGH 7.7
- TI-2026-25120 Glances has a SQL Injection in DuckDB Export via Unparameterized DDL Statements CVSS 3.1CRITICAL 9.1
- TI-2026-25118 Glances has Incomplete Secrets Redaction: /api/v4/args Endpoint Leaks Password Hash and SNMP Credentials CVSS 3.1HIGH 7.5
- TI-2026-25143 Glances Central Browser Autodiscovery Leaks Reusable Credentials to Zeroconf-Spoofed Servers CVSS 3.1HIGH 8.1
Sources
- CVE-2026-35587 · CVE Program
- CVE-2026-35587 · NVD
- FIRST EPSS
- GHSA-g5pq-48mj-jvw8 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-35587 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences