Addressable has a Regular Expression Denial of Service in Addressable templates
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-1333.
Summary
Addressable is an alternative implementation to the URI implementation that is part of Ruby's standard library. From 2.3.0 to before 2.9.0, within the URI template implementation in Addressable, two classes of URI template generate regular expressions vulnerable to catastrophic backtracking. Templates using the * (explode) modifier with any expansion operator (e.g., {foo*}, {+var*}, {#var*}, {/var*}, {.var*}, {;var*}, {?var*}, {&var*}) generate patterns with nested unbounded quantifiers that are O(2^n) when matched against a maliciously crafted URI. Templates using multiple variables with the + or # operators (e.g., {+v1,v2,v3}) generate patterns with O(n^k) complexity due to the comma separator being within the matched character class, causing ambiguous backtracking across k variables. When matched against a maliciously crafted URI, this can result in catastrophic backtracking and uncontrolled resource consumption, leading to denial of service. This vulnerability is fixed in 2.9.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| sporkmonger | addressable | 2.3.0 to before 2.9.0 | 2.9.0 | Patch available | CNA |
| — | addressable (RubyGems) | 2.3.0 to before 2.9.0 | 2.9.0 | Patch available | GHSA-h27x-rffw-24p4 |
- addressable Vendorsporkmonger Affected 2.3.0 to before 2.9.0 Fixed in 2.9.0 Patch available CNA
- addressable (RubyGems) Vendor— Affected 2.3.0 to before 2.9.0 Fixed in 2.9.0 Patch available GHSA-h27x-rffw-24p4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:addressable_project:addressable:*:*:*:*:*:ruby:*:* | 2.3.0 to before 2.9.0 | Vulnerable | Addressable Project |
- cpe:2.3:a:addressable_project:addressable:*:*:*:*:*:ruby:*:* Versions 2.3.0 to before 2.9.0 Vulnerable ·Addressable Project
Remediation
- Fix · CNA addressable (sporkmonger) Fixed in 2.9.0
- Fix · GHSA-h27x-rffw-24p4 addressable (RubyGems) Fixed in 2.9.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat 3scale API Management Platform 2 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-35611
- 2026-10-03 Alias added: GHSA-h27x-rffw-24p4
References
More Addressable Project Addressable vulnerabilities
- TI-2021-12408 Regular Expression Denial of Service in Addressable templates CVSS 3.1HIGH 7.5
Sources
- CVE-2026-35611 · CVE Program
- CVE-2026-35611 · NVD
- FIRST EPSS
- GHSA-h27x-rffw-24p4 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-35611 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences