Authentication Bypass vulnerability exists in Netmaker versions prior to 1.5.0.
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-347.
Summary
Authentication Bypass vulnerability exists in Netmaker versions prior to 1.5.0. The VerifyHostToken function in logic/jwts.go fails to validate the JWT signature when verifying host tokens. An attacker can forge a JWT signed with any arbitrary key and use it to impersonate any host in the network, gaining access to sensitive information
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/gravitl/netmaker (Go) | before 1.5.0 | 1.5.0 | Patch available | GHSA-qpv2-rwc8-c993 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/gravitl/netmaker (Go) Vendor— Affected before 1.5.0 Fixed in 1.5.0 Patch available GHSA-qpv2-rwc8-c993
Remediation
- Fix · GHSA-qpv2-rwc8-c993 github.com/gravitl/netmaker (Go) Fixed in 1.5.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-38651
- 2026-10-03 Alias added: GHSA-qpv2-rwc8-c993
References
Exploit 3
More Netmaker vulnerabilities
- TI-2022-00579 Use of Hard-coded Cryptographic Key in gravitl/netmaker CVSS 3.1CRITICAL 9.8
- TI-2023-15381 Netmaker has Hardcoded DNS Secret Key CVSS 3.1HIGH 7.5
- TI-2026-23357 Netmaker: Denial of Service via Server Shutdown Endpoint CVSS 4.0HIGH 8.7
- TI-2022-07702 Use of Hard-coded Cryptographic Key in Netmaker CVSS 3.1HIGH 8.8
- TI-2023-15383 Netmaker Privilige Escalation Vulnerability CVSS 3.1HIGH 8.8
- TI-2022-16533 Netmaker vulnerable to Insufficient Granularity of Access Control CVSS 3.1HIGH 8.8
Sources
- CVE-2026-38651 · CVE Program
- CVE-2026-38651 · NVD
- FIRST EPSS
- GHSA-qpv2-rwc8-c993 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences