An issue in Nodemailer smtp_server before v.3.18.3 allows a remote attacker to cause a…
Priority HIGH 72CWE-400Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
An issue in Nodemailer smtp_server before v.3.18.3 allows a remote attacker to cause a denial of service via the SMTPStream._write, lib/smtp-stream.js components
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00572 47th percentileScored 2026-11-07
Fix Fixed smtp-server (npm): 3.18.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | smtp-server (npm) | before 3.18.3 | 3.18.3 | Patch available | GHSA-fv2f-rw9f-v9cm |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- smtp-server (npm) Vendor— Affected before 3.18.3 Fixed in 3.18.3 Patch available GHSA-fv2f-rw9f-v9cm
Remediation
- Fix · GHSA-fv2f-rw9f-v9cm smtp-server (npm) Fixed in 3.18.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-38728
- 2026-10-03 Alias added: GHSA-fv2f-rw9f-v9cm
- 2026-10-25 EPSS moved to the below the 50th percentile
References
Sources
- CVE-2026-38728 · CVE Program
- CVE-2026-38728 · NVD
- FIRST EPSS
- GHSA-fv2f-rw9f-v9cm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences