Cockpit 2.13.5 and earlier is affected by a misconfiguration within the Bucket component…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-434.
Summary
Cockpit 2.13.5 and earlier is affected by a misconfiguration within the Bucket component _isFileTypeAllowed function where a specially crafted filename bypasses an extension filter. This allows an authenticated attacker to rename arbitrary files with the .php file extension enabling arbitrary code to be executed on the underlying server.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | cockpit-hq/cockpit (Packagist) | before 2.14.0 | 2.14.0 | Patch available | GHSA-j2rx-4jg9-79mw |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- cockpit-hq/cockpit (Packagist) Vendor— Affected before 2.14.0 Fixed in 2.14.0 Patch available GHSA-j2rx-4jg9-79mw
Remediation
- Fix · GHSA-j2rx-4jg9-79mw cockpit-hq/cockpit (Packagist) Fixed in 2.14.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-38991
- 2026-10-03 Alias added: GHSA-j2rx-4jg9-79mw
References
Sources
- CVE-2026-38991 · CVE Program
- CVE-2026-38991 · NVD
- FIRST EPSS
- GHSA-j2rx-4jg9-79mw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences