Read the docs
TI-2026-28699 Aliases CVE-2026-39816GHSA-2j9m-25xv-mp6r

Apache NiFi: Missing Execute Code Required Permission on TinkerpopClientService

Priority LOW 36CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-862.

Summary

The optional extension component TinkerpopClientService is missing the Restricted annotation with the Execute Code Required Permission in Apache NiFi 2.0.0-M1 through 2.8.0. The TinkerpopClientService supports configuration of ByteCode Submission for the Script Submission Type, enabling Groovy Script execution in the service prior to submitting the query. The missing Restricted annotation allows users without the Execute Code Permission to configure the Service in installations that use fine-grained authorization and have the optional TinkerpopClientService installed. Apache NiFi installations that do not have the nifi-other-graph-services-nar installed are not subject to this vulnerability. Upgrading to Apache NiFi 2.9.0 is the recommended mitigation.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0076 55th percentileScored 2026-11-07
Fix Fixed org.apache.nifi:nifi-other-graph-services-nar (Maven): 2.9.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache NiFi2.0.0-M1 – 2.8.0—No fix listedCNA
—org.apache.nifi:nifi-other-graph-services-nar (Maven)2.0.0-M1 to before 2.9.02.9.0Patch availableGHSA-2j9m-25xv-mp6r
  • Apache NiFi VendorApache Affected 2.0.0-M1 – 2.8.0 Fixed in — No fix listed CNA
  • org.apache.nifi:nifi-other-graph-services-nar (Maven) Vendor— Affected 2.0.0-M1 to before 2.9.0 Fixed in 2.9.0 Patch available GHSA-2j9m-25xv-mp6r

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:nifi:*:*:*:*:*:*:*:*2.0.0 to before 2.9.0VulnerableApache
  • cpe:2.3:a:apache:nifi:*:*:*:*:*:*:*:* Versions 2.0.0 to before 2.9.0 Vulnerable ·Apache

Remediation

  • Fix · GHSA-2j9m-25xv-mp6r org.apache.nifi:nifi-other-graph-services-nar (Maven) Fixed in 2.9.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-39816
  2. 2026-10-03 Alias added: GHSA-2j9m-25xv-mp6r

References

  • TI-2023-17293 Apache NiFi: Potential Code Injection with Database Services using H2 CVSS 3.1HIGH 8.8
  • TI-2020-16549 Uncontrolled resource consumption in Eclipse Jetty CVSS 3.1MEDIUM 5.3
  • TI-2019-07411 Deserialization of untrusted data in Apache Commons Beanutils CVSS 3.1HIGH 7.3
  • TI-2017-11471 Improper input validation in Apache NiFi CVSS 3.0CRITICAL 9.8
  • TI-2018-01212 XML external entity injection in Apache NiFi CVSS 3.0CRITICAL 9.8
  • TI-2021-03489 Deserialization of untrusted data in jackson-databind CVSS 3.1HIGH 8.1
See all 58 →

Sources