Read the docs
TI-2026-29543 Aliases CVE-2026-40887GHSA-9pp3-53p2-ww9v

@vendure/core has a SQL Injection vulnerability

Priority MEDIUM 49CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.

Summary

Vendure is an open-source headless commerce platform. Starting in version 1.7.4 and prior to versions 2.3.4, 3.5.7, and 3.6.2, an unauthenticated SQL injection vulnerability exists in the Vendure Shop API. A user-controlled query string parameter is interpolated directly into a raw SQL expression without parameterization or validation, allowing an attacker to execute arbitrary SQL against the database. This affects all supported database backends (PostgreSQL, MySQL/MariaDB, SQLite). The Admin API is also affected, though exploitation there requires authentication. Versions 2.3.4, 3.5.7, and 3.6.2 contain a patch. For those who are unable to upgrade immediately, Vendure has made a hotfix available that uses `RequestContextService.getLanguageCode` to validate the `languageCode` input at the boundary. This blocks injection payloads before they can reach any query. The hotfix replaces the existing `getLanguageCode` method in `packages/core/src/service/helpers/request-context/request-context.service.ts`. Invalid values are silently dropped and the channel's default language is used instead. The patched versions additionally convert the vulnerable SQL interpolation to a parameterized query as defense in depth.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01762 78th percentileScored 2026-11-07
Fix Fixed vendure (vendurehq): 3.5.7, 3.6.2, 2.3.4@vendure/core (npm): 3.5.7, 3.6.2, 2.3.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
vendurehqvendure3.0.0 to before 3.5.7; 3.6.0 to before 3.6.2; 1.7.4 to before 2.3.43.5.7, 3.6.2, 2.3.4Patch availableCNA
—@vendure/core (npm)3.0.0 to before 3.5.73.5.7Patch availableGHSA-9pp3-53p2-ww9v
—@vendure/core (npm)3.6.0 to before 3.6.23.6.2Patch availableGHSA-9pp3-53p2-ww9v
—@vendure/core (npm)1.7.4 to before 2.3.42.3.4Patch availableGHSA-9pp3-53p2-ww9v
  • vendure Vendorvendurehq Affected 3.0.0 to before 3.5.7; 3.6.0 to before 3.6.2; 1.7.4 to before 2.3.4 Fixed in 3.5.7, 3.6.2, 2.3.4 Patch available CNA
  • @vendure/core (npm) Vendor— Affected 3.0.0 to before 3.5.7 Fixed in 3.5.7 Patch available GHSA-9pp3-53p2-ww9v
  • @vendure/core (npm) Vendor— Affected 3.6.0 to before 3.6.2 Fixed in 3.6.2 Patch available GHSA-9pp3-53p2-ww9v
  • @vendure/core (npm) Vendor— Affected 1.7.4 to before 2.3.4 Fixed in 2.3.4 Patch available GHSA-9pp3-53p2-ww9v

Remediation

  • Fix · CNA vendure (vendurehq) Fixed in 3.5.7, 3.6.2, 2.3.4
  • Fix · GHSA-9pp3-53p2-ww9v @vendure/core (npm) Fixed in 3.5.7 Advisory →
  • Fix · GHSA-9pp3-53p2-ww9v @vendure/core (npm) Fixed in 3.6.2 Advisory →
  • Fix · GHSA-9pp3-53p2-ww9v @vendure/core (npm) Fixed in 2.3.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-40887
  2. 2026-10-03 Alias added: GHSA-9pp3-53p2-ww9v

References

  • TI-2026-45233 Improper authentication in vendurehq vendure CVSS 3.1CRITICAL 9.1
  • TI-2026-45227 Vendure: Stored XSS in the Admin Dashboard via unsafe HTML-stripping (innerHTML) of entity descriptions CVSS 3.1HIGH 8.7
  • TI-2026-45228 Vendure: Unauthenticated ReDoS via `regex` filter on SQLite backends CVSS 3.1HIGH 7.5
  • TI-2026-47643 Vendure 3.7.1 Cross-Channel Authorization Bypass via StockLocation and Asset Update CVSS 4.0MEDIUM 6.1
  • TI-2026-45229 Vendure: Shop API list queries can return non-public entities when filterOperator is OR CVSS 3.1MEDIUM 5.3

Sources