Statamic: Unsafe method invocation via query value resolution allows data destruction
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Statamic is a Laravel and Git powered content management system (CMS). Prior to versions 5.73.20 and 6.13.0, manipulating query parameters on Control Panel and REST API endpoints, or arguments in GraphQL queries, could result in the loss of content, assets, and user accounts. The Control Panel requires authentication with minimal permissions in order to exploit. e.g. "view entries" permission to delete entries, or "view users" permission to delete users, etc. The REST and GraphQL API exploits do not require any permissions, however neither are enabled by default. In order to be exploited, they would need to be explicitly enabled with no authentication configured, and the specific resources enabled too. Sites that enable the REST or GraphQL API without authentication should treat patching as critical priority. This has been fixed in 5.73.20 and 6.13.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| statamic | cms | before 5.73.20; 6.0.0-alpha.1 to before 6.13.0 | 5.73.20, 6.13.0 | Patch available | CNA |
| — | statamic/cms (Packagist) | before 5.73.20 | 5.73.20 | Patch available | GHSA-4jjr-vmv7-wh4w |
| — | statamic/cms (Packagist) | 6.0.0-alpha.1 to before 6.13.0 | 6.13.0 | Patch available | GHSA-4jjr-vmv7-wh4w |
- cms Vendorstatamic Affected before 5.73.20; 6.0.0-alpha.1 to before 6.13.0 Fixed in 5.73.20, 6.13.0 Patch available CNA
- statamic/cms (Packagist) Vendor— Affected before 5.73.20 Fixed in 5.73.20 Patch available GHSA-4jjr-vmv7-wh4w
- statamic/cms (Packagist) Vendor— Affected 6.0.0-alpha.1 to before 6.13.0 Fixed in 6.13.0 Patch available GHSA-4jjr-vmv7-wh4w
Remediation
- Fix · CNA cms (statamic) Fixed in 5.73.20, 6.13.0
- Fix · GHSA-4jjr-vmv7-wh4w statamic/cms (Packagist) Fixed in 5.73.20 Advisory →
- Fix · GHSA-4jjr-vmv7-wh4w statamic/cms (Packagist) Fixed in 6.13.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-41175
- 2026-10-03 Alias added: GHSA-4jjr-vmv7-wh4w
References
More Statamic vulnerabilities
- TI-2024-16191 Statamic account takeover via XSS and password reset link CVSS 3.1HIGH 8.2
- TI-2023-18622 Statamic's Antlers sanitizer cannot effectively sanitize malicious SVG CVSS 3.1MEDIUM 5.5
- TI-2021-20500 A Code Execution vulnerability exists in Statamic Version through 3.2.26 via… CVSS 3.1CRITICAL 9.8
- TI-2023-25469 Statamic CMS remote code execution via front-end form uploads CVSS 3.1CRITICAL 9.8
- TI-2023-26081 Remote code execution via form uploads in statamic/cms CVSS 3.1HIGH 8.8
- TI-2026-21980 Statamic is vulnerable to account takeover via password reset link injection CVSS 3.1CRITICAL 9.3
Sources
- CVE-2026-41175 · CVE Program
- CVE-2026-41175 · NVD
- FIRST EPSS
- GHSA-4jjr-vmv7-wh4w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences