Paperclip: Privilege Escalation via Agent-Controlled workspaceStrategy.provisionCommand Leading to OS Command Execution
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
Paperclip is a Node.js server and React UI that orchestrates a team of AI agents to run a business. Versions of @paperclipai/server prior to 2026.416.0 contain a privilege escalation vulnerability that allows an attacker with an Agent API key to execute arbitrary OS commands on the Paperclip server host. An attacker with an agent credential can escalate privileges from the agent runtime to the Paperclip server host. The vulnerability occurs because agents are allowed to update their own adapterConfig via the /agents/:id API endpoint. The configuration field adapterConfig.workspaceStrategy.provisionCommand is later executed by the server runtime. As a result, an attacker controlling an agent credential can inject arbitrary shell commands which are executed by the Paperclip server during workspace provisioning. This breaks the intended trust boundary between agent runtime configuration and server host execution, allowing a compromised or malicious agent to escalate privileges and run commands on the host system. This vulnerability allows remote code execution on the server host. @paperclipai/server version 2026.416.0 fixes the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| paperclipai | @paperclipai/server | before 2026.416.0 | 2026.416.0 | Patch available | CNA |
| — | @paperclipai/server (npm) | before 2026.416.0 | 2026.416.0 | Patch available | GHSA-265w-rf2w-cjh4 |
- @paperclipai/server Vendorpaperclipai Affected before 2026.416.0 Fixed in 2026.416.0 Patch available CNA
- @paperclipai/server (npm) Vendor— Affected before 2026.416.0 Fixed in 2026.416.0 Patch available GHSA-265w-rf2w-cjh4
Remediation
- Fix · CNA @paperclipai/server (paperclipai) Fixed in 2026.416.0
- Fix · GHSA-265w-rf2w-cjh4 @paperclipai/server (npm) Fixed in 2026.416.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-41208
- 2026-10-03 Alias added: GHSA-265w-rf2w-cjh4
- 2026-10-25 EPSS moved to the below the 50th percentile
References
More paperclipai vulnerabilities
- TI-2026-53840 Paperclip before 0.3.1 Remote Code Execution via DNS Rebinding CVSS 4.0CRITICAL 9.4
- TI-2026-83188 Command injection in Paperclip server lets API key holders run OS commands CVSS 4.0HIGH 8.7
Sources
- CVE-2026-41208 · CVE Program
- CVE-2026-41208 · NVD
- FIRST EPSS
- GHSA-265w-rf2w-cjh4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences