Read the docs
TI-2026-29829 Aliases CVE-2026-41213GHSA-jhm7-29pj-4xvf

Missing brute-force protection in node-oauth2-server

Priority MEDIUM 60CWE-1289Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Security bypass
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-307.

Summary

@node-oauth/oauth2-server is a module for implementing an OAuth2 server in Node.js. The token exchange path accepts RFC7636-invalid code_verifier values (including one-character strings) for S256 PKCE flows. Because short/weak verifiers are accepted and failed verifier attempts do not consume the authorization code, an attacker who intercepts an authorization code can brute-force code_verifier guesses online until token issuance succeeds.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00259 17th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed node-oauth2-server (node-oauth): 5.3.0@node-oauth/oauth2-server (npm): 5.3.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
node-oauthnode-oauth2-serverbefore 5.3.05.3.0Patch availableCNA
—@node-oauth/oauth2-server (npm)before 5.3.05.3.0Patch availableGHSA-jhm7-29pj-4xvf
  • node-oauth2-server Vendornode-oauth Affected before 5.3.0 Fixed in 5.3.0 Patch available CNA
  • @node-oauth/oauth2-server (npm) Vendor— Affected before 5.3.0 Fixed in 5.3.0 Patch available GHSA-jhm7-29pj-4xvf

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:node-oauth:node-oauth\/oauth2-server:*:*:*:*:*:node.js:*:*before 5.3.0Vulnerablenode-oauth
  • cpe:2.3:a:node-oauth:node-oauth\/oauth2-server:*:*:*:*:*:node.js:*:* Versions before 5.3.0 Vulnerable ·node-oauth

Remediation

  • Fix · CNA node-oauth2-server (node-oauth) Fixed in 5.3.0
  • Fix · GHSA-jhm7-29pj-4xvf @node-oauth/oauth2-server (npm) Fixed in 5.3.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-41213
  2. 2026-10-03 Alias added: GHSA-jhm7-29pj-4xvf

References

Sources