Froxlor has a PHP Code Injection via Unescaped Single Quotes in userdata.inc.php Generation (MysqlServer API)
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Froxlor is open source server administration software. Prior to version 2.3.6, `PhpHelper::parseArrayToString()` writes string values into single-quoted PHP string literals without escaping single quotes. When an admin with `change_serversettings` permission adds or updates a MySQL server via the API, the `privileged_user` parameter (which has no input validation) is written unescaped into `lib/userdata.inc.php`. Since this file is `require`d on every request via `Database::getDB()`, an attacker can inject arbitrary PHP code that executes as the web server user on every subsequent page load. Version 2.3.6 contains a patch.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| froxlor | froxlor | before 2.3.6 | 2.3.6 | Patch available | CNA |
| — | froxlor/froxlor (Packagist) | before 2.3.6 | 2.3.6 | Patch available | GHSA-gc9w-cc93-rjv8 |
- froxlor Vendorfroxlor Affected before 2.3.6 Fixed in 2.3.6 Patch available CNA
- froxlor/froxlor (Packagist) Vendor— Affected before 2.3.6 Fixed in 2.3.6 Patch available GHSA-gc9w-cc93-rjv8
Remediation
- Fix · CNA froxlor (froxlor) Fixed in 2.3.6
- Fix · GHSA-gc9w-cc93-rjv8 froxlor/froxlor (Packagist) Fixed in 2.3.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-41229
- 2026-10-03 Alias added: GHSA-gc9w-cc93-rjv8
- 2026-10-25 EPSS moved to the below the 50th percentile
References
More Froxlor vulnerabilities
- TI-2023-00300 Command Injection in froxlor/froxlor CVSS 3.1HIGH 8.8
- TI-2023-02973 Improper Restriction of Excessive Authentication Attempts in froxlor/froxlor CVSS 3.1CRITICAL 9.8
- TI-2023-01234 Authentication Bypass by Primary Weakness in froxlor/froxlor CVSS 3.1CRITICAL 9.8
- TI-2023-01911 Unrestricted Upload of File with Dangerous Type in froxlor/froxlor CVSS 3.1HIGH 8.8
- TI-2026-29837 Froxlor has Local File Inclusion via path traversal in API `def_language` parameter that leads to Remote Code Execution CVSS 3.1CRITICAL 10.0
- TI-2023-00832 Code Injection in froxlor/froxlor CVSS 3.1HIGH 8.8
Sources
- CVE-2026-41229 · CVE Program
- CVE-2026-41229 · NVD
- FIRST EPSS
- GHSA-gc9w-cc93-rjv8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences