OpenClaw < 2026.3.31 - Operator Admin Privilege Escalation via Trusted-Proxy Authentication
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
OpenClaw before 2026.3.31 contains an incomplete scope-clearing vulnerability in trusted-proxy authentication mode that allows operator.admin privilege escalation. Attackers can exploit this by declaring operator scopes on non-Control-UI clients, allowing self-declared scopes to persist on identity-bearing authentication paths and escalate privileges.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenClaw | OpenClaw | before 2026.3.31 | 2026.3.31 | Patch available | CNA |
| — | openclaw (npm) | before 2026.3.31 | 2026.3.31 | Patch available | GHSA-g374-mggx-p6xc |
- OpenClaw VendorOpenClaw Affected before 2026.3.31 Fixed in 2026.3.31 Patch available CNA
- openclaw (npm) Vendor— Affected before 2026.3.31 Fixed in 2026.3.31 Patch available GHSA-g374-mggx-p6xc
Remediation
- Fix · CNA OpenClaw (OpenClaw) Fixed in 2026.3.31
- Fix · GHSA-g374-mggx-p6xc openclaw (npm) Fixed in 2026.3.31 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
OpenClaw 2026.3.31
22 records Highest priority Priority MEDIUM 2 MEDIUM, 20 LOW
Other records, highest priority first
- TI-2026-30006 OpenClaw < 2026.3.31 - Resource Exhaustion via Unauthenticated MS Teams Webhook Body ParsingPriority MEDIUM 44
- TI-2026-29995 OpenClaw < 2026.3.31 - Unauthorized Operator Scope Access in Unauthenticated Plugin-Auth RoutesPriority MEDIUM 44
- TI-2026-29997 OpenClaw < 2026.3.31 - Environment Variable Override of Plugin Trust RootPriority LOW 38
Timeline
- 2026-10-02 Threatist record created from CVE-2026-41404
- 2026-10-03 Alias added: GHSA-g374-mggx-p6xc
- 2026-10-21 EPSS moved to the 50th–90th percentile
- 2026-10-25 EPSS moved to the below the 50th percentile
References
More Openclaw vulnerabilities
- TI-2026-25309 OpenClaw < 2026.3.28 Media Parsing Path Traversal to Arbitrary File Read CVSS 4.0HIGH 8.7
- TI-2026-20394 Exposure of resource to wrong sphere in OpenClaw CVSS 3.1HIGH 8.8
- TI-2026-27742 OpenClaw < 2026.3.24 - Arbitrary Code Execution via .npmrc in Local Plugin/Hook Installation CVSS 4.0HIGH 8.4
- TI-2026-27766 OpenClaw < 2026.3.24 - Denial of Service via Feishu Webhook Pre-Auth Body Parsing CVSS 4.0MEDIUM 6.9
- TI-2026-07315 OpenClaw bluebubbles Webhook monitor.ts handleBlueBubblesWebhookRequest improper authentication CVSS 4.0MEDIUM 6.9
- TI-2026-17789 OpenClaw < 2026.2.22 - Allowlist Bypass via Command Substitution in system.run CVSS 4.0HIGH 7.5
Sources
- CVE-2026-41404 · CVE Program
- CVE-2026-41404 · NVD
- FIRST EPSS
- GHSA-g374-mggx-p6xc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences