Read the docs
TI-2026-30231 Aliases CVE-2026-41715GHSA-pfc9-2cqg-9wq6

Reactor Netty HTTP Client Leaks Credentials On Protocol Downgrade Redirect

Priority LOW 26CWE-522Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · Low · None
Fix status
Partial Red Hat: 2 without a fix

Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-522.

Summary

In specific scenarios involving HTTP redirects from a secure to an insecure endpoint, the Reactor Netty HTTP client may leak credentials. In order for this to happen, the HTTP client must have been explicitly configured to follow redirects. Affected versions: Reactor Netty 1.0.0 through 1.0.51; 1.1.0 through 1.1.35; 1.2.0 through 1.2.17; 1.3.0 through 1.3.5.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00175 7th percentileScored 2026-11-07
Fix Partial Reactor Netty (Spring): 1.0.52, 1.1.36, 1.2.17.1 +1io.projectreactor.netty:reactor-netty (Maven): 1.3.6, 1.2.18Red Hat: 2 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
VMwareReactor Netty1.0.0 to before 1.0.52; 1.1.0 to before 1.1.36; 1.2.0 to before 1.2.17.1; 1.3.0 to before 1.3.15.11.0.52, 1.1.36, 1.2.17.1, 1.3.15.1Patch availableCNA
—io.projectreactor.netty:reactor-netty (Maven)1.3.0 to before 1.3.61.3.6Patch availableGHSA-pfc9-2cqg-9wq6
—io.projectreactor.netty:reactor-netty (Maven)1.2.0 to before 1.2.181.2.18Patch availableGHSA-pfc9-2cqg-9wq6
—io.projectreactor.netty:reactor-netty (Maven)1.1.0 – 1.1.31—No fix listedGHSA-pfc9-2cqg-9wq6
—io.projectreactor.netty:reactor-netty (Maven)1.0.0 – 1.0.48—No fix listedGHSA-pfc9-2cqg-9wq6
  • Reactor Netty VendorVMware Affected 1.0.0 to before 1.0.52; 1.1.0 to before 1.1.36; 1.2.0 to before 1.2.17.1; 1.3.0 to before 1.3.15.1 Fixed in 1.0.52, 1.1.36, 1.2.17.1, 1.3.15.1 Patch available CNA
  • io.projectreactor.netty:reactor-netty (Maven) Vendor— Affected 1.3.0 to before 1.3.6 Fixed in 1.3.6 Patch available GHSA-pfc9-2cqg-9wq6
  • io.projectreactor.netty:reactor-netty (Maven) Vendor— Affected 1.2.0 to before 1.2.18 Fixed in 1.2.18 Patch available GHSA-pfc9-2cqg-9wq6
  • io.projectreactor.netty:reactor-netty (Maven) Vendor— Affected 1.1.0 – 1.1.31 Fixed in — No fix listed GHSA-pfc9-2cqg-9wq6
  • io.projectreactor.netty:reactor-netty (Maven) Vendor— Affected 1.0.0 – 1.0.48 Fixed in — No fix listed GHSA-pfc9-2cqg-9wq6

Remediation

  • Fix · CNA Reactor Netty (Spring) Fixed in 1.0.52, 1.1.36, 1.2.17.1, 1.3.15.1
  • Fix · GHSA-pfc9-2cqg-9wq6 io.projectreactor.netty:reactor-netty (Maven) Fixed in 1.3.6 Advisory →
  • Fix · GHSA-pfc9-2cqg-9wq6 io.projectreactor.netty:reactor-netty (Maven) Fixed in 1.2.18 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Fuse 7AffectedNo fix planned: Out of support scope
Red Hat JBoss Enterprise Application Platform Expansion PackAffectedNo fix yet: Fix deferred

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-41715
  2. 2026-10-03 Alias added: GHSA-pfc9-2cqg-9wq6

References

  • TI-2026-42442 vCenter directory-traversal vulnerability KEVCVSS 3.1CRITICAL 9.8
  • TI-2024-26040 Privilege escalation in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
  • TI-2024-26039 Heap-overflow in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
  • TI-2024-24610 Out-of-bounds write in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-16914 VMware vCenter Server Out-of-Bounds Write Vulnerability KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-07303 Command injection in Aria Operations for Networks KEVCVSS 3.1CRITICAL 9.8
See all 1181 →

Sources