Deserialization of untrusted data in VMware Spring for Apache Pulsar
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
JsonPulsarHeaderMapper matched type headers against trusted packages using a prefix check, meaning that trusting any package implicitly trusted all of its subpackages. Additionally, an empty trusted-packages configuration fell back to trusting all packages rather than applying a safe default allow-list. Affected versions: Spring for Apache Pulsar 2.0.0 through 2.0.5; 1.2.0 through 1.2.17; 1.1.0 through 1.1.17.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| VMware | Spring for Apache Pulsar | 2.0.0 to before 2.0.5.1; 1.2.0 to before 1.2.17.1; 1.1.0 to before 1.1.18 | 2.0.5.1, 1.2.17.1, 1.1.18 | Patch available | CNA |
| — | org.springframework.pulsar:spring-pulsar (Maven) | 2.0.0 to before 2.0.6 | 2.0.6 | Patch available | GHSA-gg69-9wwp-6jx2 |
| — | org.springframework.pulsar:spring-pulsar (Maven) | 1.2.0 to before 1.2.18 | 1.2.18 | Patch available | GHSA-gg69-9wwp-6jx2 |
| — | org.springframework.pulsar:spring-pulsar (Maven) | up to 1.1.17 | — | No fix listed | GHSA-gg69-9wwp-6jx2 |
- Spring for Apache Pulsar VendorVMware Affected 2.0.0 to before 2.0.5.1; 1.2.0 to before 1.2.17.1; 1.1.0 to before 1.1.18 Fixed in 2.0.5.1, 1.2.17.1, 1.1.18 Patch available CNA
- org.springframework.pulsar:spring-pulsar (Maven) Vendor— Affected 2.0.0 to before 2.0.6 Fixed in 2.0.6 Patch available GHSA-gg69-9wwp-6jx2
- org.springframework.pulsar:spring-pulsar (Maven) Vendor— Affected 1.2.0 to before 1.2.18 Fixed in 1.2.18 Patch available GHSA-gg69-9wwp-6jx2
- org.springframework.pulsar:spring-pulsar (Maven) Vendor— Affected up to 1.1.17 Fixed in — No fix listed GHSA-gg69-9wwp-6jx2
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vmware:spring_for_apache_pulsar:*:*:*:*:*:*:*:* | 1.1.0 to before 1.1.18; 1.2.0 to before 1.2.17.1; 2.0.0 to before 2.0.6 | Vulnerable | VMware |
- cpe:2.3:a:vmware:spring_for_apache_pulsar:*:*:*:*:*:*:*:* Versions 1.1.0 to before 1.1.18; 1.2.0 to before 1.2.17.1; 2.0.0 to before 2.0.6 Vulnerable ·VMware
Remediation
- Fix · CNA Spring for Apache Pulsar (Spring) Fixed in 2.0.5.1, 1.2.17.1, 1.1.18
- Fix · GHSA-gg69-9wwp-6jx2 org.springframework.pulsar:spring-pulsar (Maven) Fixed in 2.0.6 Advisory →
- Fix · GHSA-gg69-9wwp-6jx2 org.springframework.pulsar:spring-pulsar (Maven) Fixed in 1.2.18 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-41732
- 2026-10-03 Alias added: GHSA-gg69-9wwp-6jx2
References
Sources
- CVE-2026-41732 · CVE Program
- CVE-2026-41732 · NVD
- FIRST EPSS
- GHSA-gg69-9wwp-6jx2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences