Cross-Site Request Forgery in admin panel of Quick.Cart
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- No fix listed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-352.
Summary
Quick.Cart is vulnerable to Cross-Site Request Forgery in admin config panel. Malicious attacker can craft special website, which when visited by the admin, will automatically send a POST request that changes admin's login and password. This software does implement simple protection against this type of attack, but it is easily bypassed by manipulating the referer header. All forms available in this software are potentially vulnerable. This issue was fixed in a patch to version 6.7 published on 09.11.2026, deployments without this patch are still vulnerable
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenSolution | Quick.Cart | up to 6.7.0 | — | No fix listed | CNA |
- Quick.Cart VendorOpenSolution Affected up to 6.7.0 Fixed in — No fix listed CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:opensolution:quick.cart:*:*:*:*:*:*:*:* | — | — | OpenSolution |
- cpe:2.3:a:opensolution:quick.cart:*:*:*:*:*:*:*:* Versions — — ·OpenSolution
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-41875
- 2026-10-03 Alias added: GHSA-79wm-hh6x-p8f7
References
More OpenSolution vulnerabilities
- TI-2024-38405 Quick.CMS 6.7 SQL Injection Authentication Bypass via Admin Login CVSS 4.0CRITICAL 9.3
- TI-2023-23205 Cross-site scripting (XSS) vulnerability in opensolution Quick CMS v.6.7 allows a local… CVSS 3.1HIGH 8.6
- TI-2023-23206 Cross-site scripting (XSS) vulnerability in opensolution Quick CMS v.6.7 allows a local… CVSS 3.1MEDIUM 5.4
- TI-2023-23204 Cross-site scripting (XSS) vulnerability in opensolution Quick CMS v.6.7 allows a local… CVSS 3.1MEDIUM 5.4
- TI-2023-23203 Cross-site scripting (XSS) vulnerability in opensolution Quick CMS v.6.7 allows a local… CVSS 3.1MEDIUM 5.4
- TI-2023-23202 Cross-site scripting (XSS) vulnerability in opensolution Quick CMS v.6.7 allows a local… CVSS 3.1MEDIUM 5.4
Sources
- CVE-2026-41875 · CVE Program
- CVE-2026-41875 · NVD
- FIRST EPSS
- GHSA-79wm-hh6x-p8f7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences