Read the docs
TI-2026-30320 Aliases CVE-2026-41918GHSA-xpj8-v2g3-x4r2

A vulnerability has been identified in RUGGEDCOM RST2428P (6GK6242-6PA00) (All versions <…

Priority LOW 26CWE-525Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Passive
Attack complexity
Low
Attack requirements
Present
Impact type
—
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA.

Summary

A vulnerability has been identified in RUGGEDCOM RST2428P (6GK6242-6PA00) (All versions < V4.0). The affected applications stores sensitive information in the browser cache when an authenticated user modify specific configurations. This could allow an authenticated attacker to access sensitive data stored in the browser.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00194 9th percentileScored 2026-11-07
Fix Fixed RUGGEDCOM RST2428P (Siemens): V4.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
SiemensRUGGEDCOM RST2428Pbefore V4.0V4.0Patch availableCNA
  • RUGGEDCOM RST2428P VendorSiemens Affected before V4.0 Fixed in V4.0 Patch available CNA

Remediation

  • Fix · CNA RUGGEDCOM RST2428P (Siemens) Fixed in V4.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-41918
  2. 2026-10-03 Alias added: GHSA-xpj8-v2g3-x4r2

References

  • TI-2026-20057 Authentication bypass in Fortinet FortiWeb KEVCVSS 3.1CRITICAL 9.4
  • TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
  • TI-2025-18911 Heap-based buffer overflow in Fortinet FortiSwitchManager KEVCVSS 3.1CRITICAL 9.8
  • TI-2025-09686 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.8
  • TI-2022-07142 Code injection in Spring Framework KEVCVSS 3.1CRITICAL 9.8
  • TI-2021-19919 Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints KEVCVSS 3.1CRITICAL 10.0
See all 2487 →

Sources