Vvveb < 1.0.8.2 Authenticated RCE via Code Editor
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
Vvveb before version 1.0.8.2 contains an authenticated remote code execution vulnerability in the admin code editor that allows low-privilege authenticated users to execute arbitrary code through insufficient file extension restrictions, with the uploaded payload then executable via subsequent unauthenticated HTTP requests. Attackers with editor, author, contributor, or site_admin roles can write a malicious .htaccess file to map arbitrary extensions to the PHP handler, then upload PHP code with that extension to achieve unauthenticated remote code execution when the file is accessed via HTTP.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Vvveb (givanz) Fixed in 1.0.8.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
givanz Vvveb 1.0.8.2
4 records Highest priority Priority HIGH 2 HIGH, 2 MEDIUM
Other records, highest priority first
- TI-2026-30338 Vvveb < 1.0.8.2 XML External Entity Injection via ImportPriority HIGH 72
- TI-2026-30333 Vvveb < 1.0.8.2 Information Disclosure via Debug Exception HandlerPriority HIGH 70
- TI-2026-30332 Vvveb < 1.0.8.2 Hard-coded Credentials Information Disclosure via phpMyAdminPriority MEDIUM 48
Timeline
- 2026-10-02 Threatist record created from CVE-2026-41934
- 2026-10-25 EPSS moved to the below the 50th percentile
References
More givanz vulnerabilities
- TI-2026-83112 Authentication bypass in Vvveb password reset enables account takeover CVSS 3.1CRITICAL 9.8
- TI-2025-28570 An issue in vvveb CMS v.1.0.6 allows a remote attacker to execute arbitrary code via the Plugin mechanism. CVSS 3.1CRITICAL 9.8
- TI-2024-18282 givanz VvvebJs 1.7.2 is vulnerable to Insecure File Upload. CVSS 3.1CRITICAL 9.8
- TI-2024-16622 givanz VvvebJs 1.7.2 suffers from a File Upload vulnerability via save.php. CVSS 3.1CRITICAL 9.8
- TI-2024-16621 A critical vulnerability has been identified in givanz VvvebJs 1.7.2, which allows both… CVSS 3.1CRITICAL 9.1
- TI-2026-83115 Authenticated IDOR in Vvveb lets admins steal other admins' API tokens CVSS 3.1CRITICAL 9.0
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences