Kirby: Read access to site, user and role information is not gated by permissions
Priority LOW 31CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
Kirby is an open-source content management system. Prior to versions 4.9.0 and 5.4.0, read access to site, user and role information is not gated by permissions. This issue has been patched in versions 4.9.0 and 5.4.0.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00231 14th percentileScored 2026-11-07
Fix Fixed kirby (getkirby): 4.9.0, 5.4.0getkirby/cms (Packagist): 4.9.0, 5.4.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| getkirby | kirby | before 4.9.0; 5.0.0 to before 5.4.0 | 4.9.0, 5.4.0 | Patch available | CNA |
| — | getkirby/cms (Packagist) | before 4.9.0 | 4.9.0 | Patch available | GHSA-2h7v-4372-f6x2 |
| — | getkirby/cms (Packagist) | 5.0.0 to before 5.4.0 | 5.4.0 | Patch available | GHSA-2h7v-4372-f6x2 |
- kirby Vendorgetkirby Affected before 4.9.0; 5.0.0 to before 5.4.0 Fixed in 4.9.0, 5.4.0 Patch available CNA
- getkirby/cms (Packagist) Vendor— Affected before 4.9.0 Fixed in 4.9.0 Patch available GHSA-2h7v-4372-f6x2
- getkirby/cms (Packagist) Vendor— Affected 5.0.0 to before 5.4.0 Fixed in 5.4.0 Patch available GHSA-2h7v-4372-f6x2
Remediation
- Fix · CNA kirby (getkirby) Fixed in 4.9.0, 5.4.0
- Fix · GHSA-2h7v-4372-f6x2 getkirby/cms (Packagist) Fixed in 4.9.0 Advisory →
- Fix · GHSA-2h7v-4372-f6x2 getkirby/cms (Packagist) Fixed in 5.4.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-42069
- 2026-10-03 Alias added: GHSA-2h7v-4372-f6x2
References
More getkirby Kirby vulnerabilities
- TI-2024-17440 An arbitrary file upload vulnerability in the Profile Image module of Kirby CMS v4.1.0… CVSS 3.1HIGH 8.8
- TI-2024-17439 An HTML injection vulnerability exists in the Edit Content Layout module of Kirby CMS… CVSS 3.1HIGH 7.1
- TI-2026-23396 Kirby CMS through 5.1.4 allows an authenticated user with 'Editor' permissions to cause a… CVSS 3.1MEDIUM 6.5
- TI-2024-17441 A stored cross-site scripting (XSS) vulnerability in the Edit Content Layout module of… CVSS 3.1MEDIUM 6.1
- TI-2018-10413 An issue was discovered in Kirby 2.5.12. CVSS 3.1MEDIUM 5.4
- TI-2024-17438 Kirby CMS v4.1.0 was discovered to contain a reflected self-XSS vulnerability via the URL parameter. CVSS 3.1MEDIUM 4.7
Sources
- CVE-2026-42069 · CVE Program
- CVE-2026-42069 · NVD
- FIRST EPSS
- GHSA-2h7v-4372-f6x2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences