yeoman-environment Vulnerable to Arbitrary Package Installation without User Confirmation
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-829.
Summary
Yeoman Environment provides an API to discover, create, and run generators, and to configure where and how a generator is resolved. Versions 2.9.0 through 6.0.0 install missing local generator packages from caller-supplied package names without user confirmation. In downstream consumers that pass attacker-controlled project configuration into this path, this can result in arbitrary package installation and code execution during CLI bootstrap. The vulnerable method is installLocalGenerators(), which calls repository.install() directly without prompting the user. This issue has been fixed in version 6.0.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| yeoman | environment | 2.9.0 to before 6.0.1 | 6.0.1 | Patch available | CNA |
| — | yeoman-environment (npm) | 2.9.0 to before 6.0.1 | 6.0.1 | Patch available | GHSA-vv9j-gjw2-j8wp |
- environment Vendoryeoman Affected 2.9.0 to before 6.0.1 Fixed in 6.0.1 Patch available CNA
- yeoman-environment (npm) Vendor— Affected 2.9.0 to before 6.0.1 Fixed in 6.0.1 Patch available GHSA-vv9j-gjw2-j8wp
Remediation
- Fix · CNA environment (yeoman) Fixed in 6.0.1
- Fix · GHSA-vv9j-gjw2-j8wp yeoman-environment (npm) Fixed in 6.0.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-42089
- 2026-10-03 Alias added: GHSA-vv9j-gjw2-j8wp
References
Sources
- CVE-2026-42089 · CVE Program
- CVE-2026-42089 · NVD
- FIRST EPSS
- GHSA-vv9j-gjw2-j8wp · GitHub Advisory Database · CC BY 4.0
- CVE-2026-42089 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences