Reflected XSS via backslash bypass in GraphiQL js_escape in absinthe_plug
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation (XSS) vulnerability in absinthe-graphql absinthe_plug allows reflected cross-site scripting via the GraphiQL interface. 'Elixir.Absinthe.Plug.GraphiQL':js_escape/1 in lib/absinthe/plug/graphiql.ex escapes single quotes and newlines in the query GET parameter before embedding it in an inline JavaScript string, but does not escape backslashes. An attacker can bypass the escaping by prefixing a quote with a backslash (e.g. \'), breaking out of the string context and executing arbitrary JavaScript in the victim's browser. This issue affects absinthe_plug: from 1.2.0 before 1.5.10.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| absinthe-graphql | absinthe_plug | 1.2.0 to before 1.5.10 | 1.5.10 | Patch available | CNA |
| — | absinthe_plug (Hex) | 1.2.0 – 1.5.9 | — | No fix listed | GHSA-c62g-j346-39v5 |
- absinthe_plug Vendorabsinthe-graphql Affected 1.2.0 to before 1.5.10 Fixed in 1.5.10 Patch available CNA
- absinthe_plug (Hex) Vendor— Affected 1.2.0 – 1.5.9 Fixed in — No fix listed GHSA-c62g-j346-39v5
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:absinthe-graphql:absinthe.plug:*:*:*:*:*:*:*:* | 1.2.0 to before 1.5.10 | Vulnerable | absinthe-graphql |
- cpe:2.3:a:absinthe-graphql:absinthe.plug:*:*:*:*:*:*:*:* Versions 1.2.0 to before 1.5.10 Vulnerable ·absinthe-graphql
Remediation
- Fix · CNA absinthe_plug (absinthe-graphql) Fixed in 1.5.10
Timeline
- 2026-10-02 Threatist record created from CVE-2026-42794
- 2026-10-03 Alias added: GHSA-c62g-j346-39v5
References
Patch 1
Advisory 4
Sources
- CVE-2026-42794 · CVE Program
- CVE-2026-42794 · NVD
- FIRST EPSS
- GHSA-c62g-j346-39v5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences