Arelle < 2.39.10 Unauthenticated RCE via /rest/configure
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-306.
Summary
Arelle before 2.39.10 contains an unauthenticated remote code execution vulnerability in the /rest/configure REST endpoint that accepts a plugins query parameter and forwards it to the plugin manager without authentication or authorization. Attackers can supply a URL to a malicious Python file through the plugins parameter, causing the Arelle webserver to download and execute the attacker-controlled code within the Arelle process with its privileges.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Arelle | Arelle | before 2.39.10 | 2.39.10 | Patch available | CNA |
- Arelle VendorArelle Affected before 2.39.10 Fixed in 2.39.10 Patch available CNA
Remediation
- Fix · CNA Arelle (Arelle) Fixed in 2.39.10
Timeline
- 2026-10-02 Threatist record created from CVE-2026-42796
- 2026-10-03 Alias added: GHSA-m48p-vcj6-wq3j
- 2026-10-14 EPSS moved to the 90th–95th percentile
- 2026-10-25 EPSS moved to the 50th–90th percentile
Sources
- CVE-2026-42796 · CVE Program
- CVE-2026-42796 · NVD
- FIRST EPSS
- GHSA-m48p-vcj6-wq3j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences