Grav: Low-privileged API users can create super-admin accounts via blueprint-upload
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Privilege escalation, Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-269 and CWE-434.
Summary
Grav is a file-based Web platform. In Grav 2.0.0-beta.2, a low-privileged authenticated API user with api.media.write can abuse /api/v1/blueprint-upload to write an arbitrary YAML file into user/accounts/, then log in as the newly created account with api.super privileges. This results in full administrative compromise of the Grav API. This vulnerability is fixed in API 1.0.0-beta.17.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| getgrav | grav | 2.0.0-beta.2 | — | No fix listed | CNA |
| — | getgrav/grav (Packagist) | before 2.0.0-beta.4 | 2.0.0-beta.4 | Patch available | GHSA-6xx2-m8wv-756h |
- grav Vendorgetgrav Affected 2.0.0-beta.2 Fixed in — No fix listed CNA
- getgrav/grav (Packagist) Vendor— Affected before 2.0.0-beta.4 Fixed in 2.0.0-beta.4 Patch available GHSA-6xx2-m8wv-756h
Remediation
- Fix · GHSA-6xx2-m8wv-756h getgrav/grav (Packagist) Fixed in 2.0.0-beta.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-42844
- 2026-10-03 Alias added: GHSA-6xx2-m8wv-756h
References
More getgrav Grav vulnerabilities
- TI-2025-28971 Cross Site Scripting vulnerability in grav v.1.7.48 and before allows an attacker to… CVSS 3.1CRITICAL 9.8
- TI-2021-22428 GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2) CVSS 4.0CRITICAL 9.3
- TI-2025-41064 In grav <1.7.49.5, a SSRF (Server-Side Request Forgery) vector may be triggered via Twig… CVSS 3.1CRITICAL 9.1
- TI-2026-30888 Grav: Unauthenticated Path Traversal & Arbitrary File Write in FormFlash component. CVSS 4.0HIGH 8.8
- TI-2025-40773 Security Sandbox Bypass with SSTI (Server Side Template Injection) in the Grav CMS CVSS 3.1HIGH 8.8
- TI-2025-40768 Grav is vulnerable to RCE via SSTI through Twig Sandbox Bypass CVSS 4.0HIGH 8.7
Sources
- CVE-2026-42844 · CVE Program
- CVE-2026-42844 · NVD
- FIRST EPSS
- GHSA-6xx2-m8wv-756h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences