batman-adv: Avoid double-rtnl_lock ELP metric worker
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-667 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: batman-adv: Avoid double-rtnl_lock ELP metric worker batadv_v_elp_get_throughput() might be called when the RTNL lock is already held. This could be problematic when the work queue item is cancelled via cancel_delayed_work_sync() in batadv_v_elp_iface_disable(). In this case, an rtnl_lock() would cause a deadlock. To avoid this, rtnl_trylock() was used in this function to skip the retrieval of the ethtool information in case the RTNL lock was already held. But for cfg80211 interfaces, batadv_get_real_netdev() was called - which also uses rtnl_lock(). The approach for __ethtool_get_link_ksettings() must also be used instead and the lockless version __batadv_get_real_netdev() has to be called.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.10.235 to before 5.10.253; 5.15.179 to before 5.15.203; 6.1.129 to before 6.1.167; 6.6.79 to before 6.6.130; 6.12.16 to before 6.12.78; 5.4.291 to before 5.5; 6.13.4 to before 6.14 | 5.10.253, 5.15.203, 6.1.167, 6.6.130, 6.12.78, 5.5, 6.14 | Patch available | CNA |
| Linux | Linux | 6.14 and later | 5.10.253, 5.15.203, 6.1.167, 6.6.130, 6.12.78, 6.18.19, 6.19.9, 7.0 | Patch available | CNA |
- Linux VendorLinux Affected 5.10.235 to before 5.10.253; 5.15.179 to before 5.15.203; 6.1.129 to before 6.1.167; 6.6.79 to before 6.6.130; 6.12.16 to before 6.12.78; 5.4.291 to before 5.5; 6.13.4 to before 6.14 Fixed in 5.10.253, 5.15.203, 6.1.167, 6.6.130, 6.12.78, 5.5, 6.14 Patch available CNA
- Linux VendorLinux Affected 6.14 and later Fixed in 5.10.253, 5.15.203, 6.1.167, 6.6.130, 6.12.78, 6.18.19, 6.19.9, 7.0 Patch available CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.4.291 to before 5.5; 5.10.235 to before 5.10.253; 5.15.179 to before 5.15.203; 6.1.129 to before 6.1.167; 6.6.79 to before 6.6.130; 6.12.16 to before 6.12.78; 6.13.4 to before 6.14; 6.14.1 to before 6.18.19; 6.19 to before 6.19.9 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:-:*:*:*:*:*:* | 6.14 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:rc3:*:*:*:*:*:* | 6.14 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:rc4:*:*:*:*:*:* | 6.14 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:rc5:*:*:*:*:*:* | 6.14 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:rc6:*:*:*:*:*:* | 6.14 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:rc7:*:*:*:*:*:* | 6.14 rc7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc1:*:*:*:*:*:* | 7.0 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:7.0:rc2:*:*:*:*:*:* | 7.0 rc2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.4.291 to before 5.5; 5.10.235 to before 5.10.253; 5.15.179 to before 5.15.203; 6.1.129 to before 6.1.167; 6.6.79 to before 6.6.130; 6.12.16 to before 6.12.78; 6.13.4 to before 6.14; 6.14.1 to before 6.18.19; 6.19 to before 6.19.9 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:-:*:*:*:*:*:* Versions 6.14 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:rc3:*:*:*:*:*:* Versions 6.14 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:rc4:*:*:*:*:*:* Versions 6.14 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:rc5:*:*:*:*:*:* Versions 6.14 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:rc6:*:*:*:*:*:* Versions 6.14 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:rc7:*:*:*:*:*:* Versions 6.14 rc7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc1:*:*:*:*:*:* Versions 7.0 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:7.0:rc2:*:*:*:*:*:* Versions 7.0 rc2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.10.253, 5.15.203, 6.1.167, 6.6.130, 6.12.78, 5.5, 6.14
- Fix · CNA Linux (Linux) Fixed in 5.10.253, 5.15.203, 6.1.167, 6.6.130, 6.12.78, 6.18.19, 6.19.9, 7.0
Vendor assessments
Red Hat
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2026-43382
- 2026-10-03 Alias added: GHSA-36qq-553f-w4ww
References
Patch 8
- https://git.kernel.org/stable/c/4c3ae249431b4fcb315d7dfb4c3a13f9e443fd9b
- https://git.kernel.org/stable/c/192f40ad8a7dac58dae9199a065dbf7e6e67b75b
- https://git.kernel.org/stable/c/fa7b4edfbabdf9235b0ab4bea297fc12b3bec9ca
- https://git.kernel.org/stable/c/f3ca45673dab0514a887231de6f3243a699d5bfd
- https://git.kernel.org/stable/c/b7e5d8ddfdf1d6e9e0808d1adf7736a107372d77
- https://git.kernel.org/stable/c/2ab9f2531d37775cd79228c1f5d80e6bd08d11d3
- https://git.kernel.org/stable/c/77808fe7d03ad0062840b95f431869a8b3d88b24
- https://git.kernel.org/stable/c/cfc83a3c71517b59c1047db57da31e26a9dc2f33
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2026-43382 · CVE Program
- CVE-2026-43382 · NVD
- FIRST EPSS
- GHSA-36qq-553f-w4ww · GitHub Advisory Database · CC BY 4.0
- CVE-2026-43382 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences