FORTIFY_SOURCE disabled
Priority LOW 18CWE-693Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-693.
Summary
Netatalk 3.1.2 through 4.4.2 is compiled without FORTIFY_SOURCE, which disables built-in buffer overflow detection at runtime, potentially allowing a remote attacker to cause a minor denial of service via memory errors that would otherwise be caught and safely terminated by runtime protection.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00335 26th percentileScored 2026-11-07
Fix Fixed Netatalk (Netatalk): 4.5.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Netatalk (Netatalk) Fixed in 4.5.0
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-44071
- 2026-10-03 Alias added: GHSA-jwvm-wx3q-6rjh
References
More Netatalk vulnerabilities
- TI-2018-01076 Out-of-bounds write in Netatalk CVSS 3.1CRITICAL 9.8
- TI-2024-25689 Netatalk before 3.2.1 has an off-by-one error and resultant heap-based buffer overflow… CVSS 3.1CRITICAL 9.8
- TI-2024-25690 Netatalk before 3.2.1 has an off-by-one error, and resultant heap-based buffer overflow… CVSS 3.1HIGH 7.5
- TI-2022-22254 Netatalk through 3.1.13 has an afp_getappl heap-based buffer overflow resulting in code… CVSS 3.1HIGH 7.8
- TI-2022-21402 Heap-based buffer overflow in Netatalk CVSS 3.1CRITICAL 9.8
- TI-2022-07290 Improper handling of exceptional conditions in Netatalk CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-44071 · CVE Program
- CVE-2026-44071 · NVD
- FIRST EPSS
- GHSA-jwvm-wx3q-6rjh · GitHub Advisory Database · CC BY 4.0
- CVE-2026-44071 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences