fluent-plugin-opentelemetry: Denial of Service (DoS) via Large Payloads and Decompression Bombs in `in_opentelemetry`
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-770.
Summary
fluent-plugin-opentelemetry is a Fluentd input and output plugin for forwarding OpenTelemetry Protocol data. Prior to 0.5.3, the in_opentelemetry HTTP input read the entire incoming request body and decompressed payloads into memory without enforcing maximum size thresholds. When an OpenTelemetry ingestion endpoint was exposed to an untrusted network, an attacker could send an excessively large request or a highly compressed payload that expanded in memory. The resulting memory exhaustion could cause the operating system to terminate the Fluentd process, disrupting all log collection and forwarding on the affected node. This issue is fixed in version 0.5.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| fluent-plugins-nursery | fluent-plugin-opentelemetry | before 0.5.3 | 0.5.3 | Patch available | CNA |
| — | fluent-plugin-opentelemetry (RubyGems) | before 0.5.3 | 0.5.3 | Patch available | GHSA-2jc5-xhx8-qj6h |
- fluent-plugin-opentelemetry Vendorfluent-plugins-nursery Affected before 0.5.3 Fixed in 0.5.3 Patch available CNA
- fluent-plugin-opentelemetry (RubyGems) Vendor— Affected before 0.5.3 Fixed in 0.5.3 Patch available GHSA-2jc5-xhx8-qj6h
Remediation
- Fix · CNA fluent-plugin-opentelemetry (fluent-plugins-nursery) Fixed in 0.5.3
- Fix · GHSA-2jc5-xhx8-qj6h fluent-plugin-opentelemetry (RubyGems) Fixed in 0.5.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-44163
- 2026-10-03 Alias added: GHSA-2jc5-xhx8-qj6h
References
Other 3
Sources
- CVE-2026-44163 · CVE Program
- CVE-2026-44163 · NVD
- FIRST EPSS
- GHSA-2jc5-xhx8-qj6h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences