Kirby: Cross-site scripting (XSS) from list field content in the site frontend
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Kirby is an open-source content management system. In versions prior to 4.9.1 and 5.4.1, Kirby did not securely sanitize the contents of the list field on save, leaving it vulnerable to cross-site scripting (XSS). Kirby's list field stores its formatted content as HTML, and unlike other field types, its HTML special characters cannot be escaped without losing the formatting. Sanitization was only enforced client-side in the Panel, while the server did not sanitize the content on save. As a result, an attacker could bypass the Panel and send malicious HTML directly to Kirby's API, storing unsanitized markup in the content file. That markup would then be rendered on the site frontend and executed in the browsers of site visitors and logged-in users browsing the site, resulting in persistent XSS. This issue has been fixed in versions 4.9.1 and 5.4.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| getkirby | kirby | before 4.9.1; 5.0.0 to before 5.4.1 | 4.9.1, 5.4.1 | Patch available | CNA |
| — | getkirby/cms (Packagist) | before 4.9.1 | 4.9.1 | Patch available | GHSA-5fhx-9q32-q257 |
| — | getkirby/cms (Packagist) | 5.0.0 to before 5.4.1 | 5.4.1 | Patch available | GHSA-5fhx-9q32-q257 |
- kirby Vendorgetkirby Affected before 4.9.1; 5.0.0 to before 5.4.1 Fixed in 4.9.1, 5.4.1 Patch available CNA
- getkirby/cms (Packagist) Vendor— Affected before 4.9.1 Fixed in 4.9.1 Patch available GHSA-5fhx-9q32-q257
- getkirby/cms (Packagist) Vendor— Affected 5.0.0 to before 5.4.1 Fixed in 5.4.1 Patch available GHSA-5fhx-9q32-q257
Remediation
- Fix · CNA kirby (getkirby) Fixed in 4.9.1, 5.4.1
- Fix · GHSA-5fhx-9q32-q257 getkirby/cms (Packagist) Fixed in 4.9.1 Advisory →
- Fix · GHSA-5fhx-9q32-q257 getkirby/cms (Packagist) Fixed in 5.4.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-44175
- 2026-10-03 Alias added: GHSA-5fhx-9q32-q257
References
More getkirby vulnerabilities
- TI-2024-17440 An arbitrary file upload vulnerability in the Profile Image module of Kirby CMS v4.1.0… CVSS 3.1HIGH 8.8
- TI-2024-17439 An HTML injection vulnerability exists in the Edit Content Layout module of Kirby CMS… CVSS 3.1HIGH 7.1
- TI-2026-23396 Kirby CMS through 5.1.4 allows an authenticated user with 'Editor' permissions to cause a… CVSS 3.1MEDIUM 6.5
- TI-2024-17441 A stored cross-site scripting (XSS) vulnerability in the Edit Content Layout module of… CVSS 3.1MEDIUM 6.1
- TI-2018-10413 An issue was discovered in Kirby 2.5.12. CVSS 3.1MEDIUM 5.4
- TI-2024-17438 Kirby CMS v4.1.0 was discovered to contain a reflected self-XSS vulnerability via the URL parameter. CVSS 3.1MEDIUM 4.7
Sources
- CVE-2026-44175 · CVE Program
- CVE-2026-44175 · NVD
- FIRST EPSS
- GHSA-5fhx-9q32-q257 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences