Kirby: Pre-authentication path traversal and PHP file inclusion during user lookup
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-98.
Summary
Kirby is an open-source content management system. In versions 5.3.0 and above but prior to 5.4.1, Kirby did not correctly validate the provided user ID, resulting in a path traversal vulnerability. Version 5.3.0 introduced a performance improvement to the Users collection that loaded user objects lazily when first needed. Users were queried by their ID, which was then used to locate the corresponding account directory under site/accounts. This affected the authentication API (accessible to unauthenticated requests), the users API (accessible only to authenticated users), and any other place that uses $users->find() to look up an individual user by a request-provided email or ID. As a result, an attacker could trigger arbitrary PHP file inclusion of files named index.php (for example, the main PHP files of plugins), the impact of which depends on the logic those files contain. It also allowed probing for the existence of arbitrary directories on the server, letting attackers fingerprint the server and site setup, including installed plugins and the content structure. This issue has been fixed in version 5.4.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| getkirby | kirby | 5.3.0 to before 5.4.1 | 5.4.1 | Patch available | CNA |
| — | getkirby/cms (Packagist) | 5.3.0 to before 5.4.1 | 5.4.1 | Patch available | GHSA-9hx7-c53c-v6x8 |
- kirby Vendorgetkirby Affected 5.3.0 to before 5.4.1 Fixed in 5.4.1 Patch available CNA
- getkirby/cms (Packagist) Vendor— Affected 5.3.0 to before 5.4.1 Fixed in 5.4.1 Patch available GHSA-9hx7-c53c-v6x8
Remediation
- Fix · CNA kirby (getkirby) Fixed in 5.4.1
- Fix · GHSA-9hx7-c53c-v6x8 getkirby/cms (Packagist) Fixed in 5.4.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-44177
- 2026-10-03 Alias added: GHSA-9hx7-c53c-v6x8
References
More getkirby vulnerabilities
- TI-2024-17440 An arbitrary file upload vulnerability in the Profile Image module of Kirby CMS v4.1.0… CVSS 3.1HIGH 8.8
- TI-2024-17439 An HTML injection vulnerability exists in the Edit Content Layout module of Kirby CMS… CVSS 3.1HIGH 7.1
- TI-2026-23396 Kirby CMS through 5.1.4 allows an authenticated user with 'Editor' permissions to cause a… CVSS 3.1MEDIUM 6.5
- TI-2024-17441 A stored cross-site scripting (XSS) vulnerability in the Edit Content Layout module of… CVSS 3.1MEDIUM 6.1
- TI-2018-10413 An issue was discovered in Kirby 2.5.12. CVSS 3.1MEDIUM 5.4
- TI-2024-17438 Kirby CMS v4.1.0 was discovered to contain a reflected self-XSS vulnerability via the URL parameter. CVSS 3.1MEDIUM 4.7
Sources
- CVE-2026-44177 · CVE Program
- CVE-2026-44177 · NVD
- FIRST EPSS
- GHSA-9hx7-c53c-v6x8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences