PrestaShop: Stored XSS executable in customer service view
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
PrestaShop is an open source e-commerce web application. Prior to 8.2.6 and 9.1.1, there is a stored Cross-Site Scripting (XSS) vulnerability in the PrestaShop back-office Customer Service view. An unauthenticated attacker can submit the public Contact Us form with a malicious email address. The payload is stored in the database and executed when a back-office employee opens the affected customer thread, enabling session hijacking and full back-office takeover. This vulnerability is fixed in 8.2.6 and 9.1.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PrestaShop | PrestaShop | before 8.2.6; 9.0.0-alpha.1 to before 9.1.1 | 8.2.6, 9.1.1 | Patch available | CNA |
| — | prestashop/prestashop (Packagist) | before 8.2.6 | 8.2.6 | Patch available | GHSA-w9f3-qc75-qgx9 |
| — | prestashop/prestashop (Packagist) | 9.0.0 to before 9.1.1 | 9.1.1 | Patch available | GHSA-w9f3-qc75-qgx9 |
- PrestaShop VendorPrestaShop Affected before 8.2.6; 9.0.0-alpha.1 to before 9.1.1 Fixed in 8.2.6, 9.1.1 Patch available CNA
- prestashop/prestashop (Packagist) Vendor— Affected before 8.2.6 Fixed in 8.2.6 Patch available GHSA-w9f3-qc75-qgx9
- prestashop/prestashop (Packagist) Vendor— Affected 9.0.0 to before 9.1.1 Fixed in 9.1.1 Patch available GHSA-w9f3-qc75-qgx9
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:prestashop:prestashop:*:*:*:*:*:*:*:* | — | — | PrestaShop |
- cpe:2.3:a:prestashop:prestashop:*:*:*:*:*:*:*:* Versions — — ·PrestaShop
Remediation
- Fix · CNA PrestaShop (PrestaShop) Fixed in 8.2.6, 9.1.1
- Fix · GHSA-w9f3-qc75-qgx9 prestashop/prestashop (Packagist) Fixed in 8.2.6 Advisory →
- Fix · GHSA-w9f3-qc75-qgx9 prestashop/prestashop (Packagist) Fixed in 9.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-44212
- 2026-10-03 Alias added: GHSA-w9f3-qc75-qgx9
References
More PrestaShop vulnerabilities
- TI-2024-27717 An issue in Prestashop v.8.1.7 and before allows a remote attacker to execute arbitrary… CVSS 3.1CRITICAL 9.8
- TI-2023-14167 Prestashop posstaticfooter <= 1.0.0 is vulnerable to SQL Injection via posstaticfooter::getPosCurrentHook(). CVSS 3.1CRITICAL 9.8
- TI-2023-14166 Prestashop possearchproducts 1.7 is vulnerable to SQL Injection via PosSearch::find(). CVSS 3.1CRITICAL 9.8
- TI-2023-10662 PrestaShop dpdfrance <6.1.3 is vulnerable to SQL Injection via dpdfrance/ajax.php. CVSS 3.1CRITICAL 9.8
- TI-2024-23013 PrestaShop vulnerable to XSS via customer contact form in FO, through file upload CVSS 3.1CRITICAL 9.7
- TI-2023-14154 An SQL injection vulnerability in the Payplug (payplug) module for PrestaShop, in… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-44212 · CVE Program
- CVE-2026-44212 · NVD
- FIRST EPSS
- GHSA-w9f3-qc75-qgx9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences