css_parser allows to MITM included https css urls
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Spoofing, Code execution
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-295 and CWE-829.
Summary
css_parser is a Ruby CSS parser. Prior to 2.1.0 and 1.22.0, the CSS Parser gem does not validate HTTPS connections, allowing a Man-in-the-Middle (MITM) attacker to inject or modify CSS content when stylesheets are loaded via HTTPS. The connection is established with OpenSSL::SSL::VERIFY_NONE, meaning any HTTPS certificate—even entirely untrusted—will be accepted without validation. This vulnerability is fixed in 2.1.0 and 1.22.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| premailer | css_parser | 2.0.0 to before 2.1.0; before 1.22.0 | 2.1.0, 1.22.0 | Patch available | CNA |
| — | css_parser (RubyGems) | 2.0.0 to before 2.1.0 | 2.1.0 | Patch available | GHSA-ff6c-w6qf-7xqc |
| — | css_parser (RubyGems) | before 1.22.0 | 1.22.0 | Patch available | GHSA-ff6c-w6qf-7xqc |
- css_parser Vendorpremailer Affected 2.0.0 to before 2.1.0; before 1.22.0 Fixed in 2.1.0, 1.22.0 Patch available CNA
- css_parser (RubyGems) Vendor— Affected 2.0.0 to before 2.1.0 Fixed in 2.1.0 Patch available GHSA-ff6c-w6qf-7xqc
- css_parser (RubyGems) Vendor— Affected before 1.22.0 Fixed in 1.22.0 Patch available GHSA-ff6c-w6qf-7xqc
Remediation
- Fix · CNA css_parser (premailer) Fixed in 2.1.0, 1.22.0
- Fix · GHSA-ff6c-w6qf-7xqc css_parser (RubyGems) Fixed in 2.1.0 Advisory →
- Fix · GHSA-ff6c-w6qf-7xqc css_parser (RubyGems) Fixed in 1.22.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat 3scale API Management Platform 2 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-44312
- 2026-10-03 Alias added: GHSA-ff6c-w6qf-7xqc
References
Other 6
- https://github.com/premailer/css_parser/security/advisories/GHSA-ff6c-w6qf-7xqc
- https://github.com/premailer/css_parser/issues/185
- https://github.com/premailer/css_parser/commit/35e689c904225add78e0c488cf04bad052666449
- https://github.com/premailer/css_parser/commit/e0c95d5abe91b237becb90ff316531a6547ada18
- https://github.com/premailer/css_parser
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/css_parser/CVE-2026-44312.yml
More premailer vulnerabilities
- TI-2026-38747 css_parser: SSRF and Local File Disclosure in `CssParser::Parser#read_remote_file` CVSS 4.0HIGH 8.9
Sources
- CVE-2026-44312 · CVE Program
- CVE-2026-44312 · NVD
- FIRST EPSS
- GHSA-ff6c-w6qf-7xqc · GitHub Advisory Database · CC BY 4.0
- CVE-2026-44312 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences