Read the docs
TI-2026-32782 Aliases CVE-2026-44911GHSA-qvj8-gwpm-4x49

Apache NiFi: Incorrect Authorization for Configuration Verification Requests

Priority LOW 13CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
Security bypass
Confidentiality · integrity · availability
Low · Low · Low
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.

Summary

Authorization handling for component configuration verification requests in Apache NiFi 1.15.0 through 2.9.0 allows clients with read access to submit proposed configuration properties. The proposed properties override current configuration, enabling users with read access to invoke predefined verification methods with alternative settings. Apache NiFi installations that do not implement different levels of authorization for viewing and modifying component configuration are not subject to this vulnerability. Upgrading to Apache NiFi 2.10.0 is the recommended mitigation, requiring write access to submit configuration verification requests.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00516 44th percentileScored 2026-11-07
Fix Fixed org.apache.nifi:nifi-web-api (Maven): 2.10.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache NiFi1.15.0 – 2.9.0—No fix listedCNA
—org.apache.nifi:nifi-web-api (Maven)1.15.0 to before 2.10.02.10.0Patch availableGHSA-qvj8-gwpm-4x49
  • Apache NiFi VendorApache Affected 1.15.0 – 2.9.0 Fixed in — No fix listed CNA
  • org.apache.nifi:nifi-web-api (Maven) Vendor— Affected 1.15.0 to before 2.10.0 Fixed in 2.10.0 Patch available GHSA-qvj8-gwpm-4x49

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:nifi:*:*:*:*:*:*:*:*1.15.0 to before 2.10.0VulnerableApache
  • cpe:2.3:a:apache:nifi:*:*:*:*:*:*:*:* Versions 1.15.0 to before 2.10.0 Vulnerable ·Apache

Remediation

  • Fix · GHSA-qvj8-gwpm-4x49 org.apache.nifi:nifi-web-api (Maven) Fixed in 2.10.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-44911
  2. 2026-10-03 Alias added: GHSA-qvj8-gwpm-4x49

References

  • TI-2023-17293 Apache NiFi: Potential Code Injection with Database Services using H2 CVSS 3.1HIGH 8.8
  • TI-2020-16549 Uncontrolled resource consumption in Eclipse Jetty CVSS 3.1MEDIUM 5.3
  • TI-2019-07411 Deserialization of untrusted data in Apache Commons Beanutils CVSS 3.1HIGH 7.3
  • TI-2017-11471 Improper input validation in Apache NiFi CVSS 3.0CRITICAL 9.8
  • TI-2018-01212 XML external entity injection in Apache NiFi CVSS 3.0CRITICAL 9.8
  • TI-2021-03489 Deserialization of untrusted data in jackson-databind CVSS 3.1HIGH 8.1
See all 58 →

Sources