Read the docs
TI-2026-32784 Aliases CVE-2026-44914GHSA-r2g5-993q-664g

Apache NiFi: Missing Authorization of Restricted Permissions when Replacing Flow Contents

Priority LOW 36CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-862.

Summary

Apache NiFi 1.12.0 through 2.9.0 are missing authorization when replacing Process Groups that include extension components with specific Required Permissions based on the Restricted annotation. The Restricted annotation indicates additional privileges required, but framework authorization did not check restricted status when handling requests to replace Process Groups. The missing authorization permits a user with general write access to add components with Restricted status. Apache NiFi installations that do not implement specific authorization for Restricted components are not subject to this vulnerability because the framework enforces write permissions as the security boundary. Upgrading to Apache NiFi 2.9.0 is the recommended mitigation, which removes the implementation of Restricted status authorization from the framework.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0066 51st percentileScored 2026-11-07
Fix Fixed org.apache.nifi:nifi-web-api (Maven): 2.9.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache NiFi1.12.0 – 2.9.0—No fix listedCNA
—org.apache.nifi:nifi-web-api (Maven)1.12.0 to before 2.9.02.9.0Patch availableGHSA-r2g5-993q-664g
  • Apache NiFi VendorApache Affected 1.12.0 – 2.9.0 Fixed in — No fix listed CNA
  • org.apache.nifi:nifi-web-api (Maven) Vendor— Affected 1.12.0 to before 2.9.0 Fixed in 2.9.0 Patch available GHSA-r2g5-993q-664g

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:nifi:*:*:*:*:*:*:*:*1.12.0 to before 2.10.0VulnerableApache
  • cpe:2.3:a:apache:nifi:*:*:*:*:*:*:*:* Versions 1.12.0 to before 2.10.0 Vulnerable ·Apache

Remediation

  • Fix · GHSA-r2g5-993q-664g org.apache.nifi:nifi-web-api (Maven) Fixed in 2.9.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-44914
  2. 2026-10-03 Alias added: GHSA-r2g5-993q-664g
  3. 2026-10-07 EPSS moved to the 50th–90th percentile

References

  • TI-2023-17293 Apache NiFi: Potential Code Injection with Database Services using H2 CVSS 3.1HIGH 8.8
  • TI-2020-16549 Uncontrolled resource consumption in Eclipse Jetty CVSS 3.1MEDIUM 5.3
  • TI-2019-07411 Deserialization of untrusted data in Apache Commons Beanutils CVSS 3.1HIGH 7.3
  • TI-2017-11471 Improper input validation in Apache NiFi CVSS 3.0CRITICAL 9.8
  • TI-2018-01212 XML external entity injection in Apache NiFi CVSS 3.0CRITICAL 9.8
  • TI-2021-03489 Deserialization of untrusted data in jackson-databind CVSS 3.1HIGH 8.1
See all 58 →

Sources