Command injection through unsanitized YAML parameter in Rancher
Priority MEDIUM 45CWE-95Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-95.
Summary
A command injection vulnerability in the Rancher Manager cluster before 2.14.2 import endpoint /v3/import/{token}_{clusterId}.yaml through unsanitized YAML parameters could allow remote attackers to break out of an image, and execute e.g. malicious containers.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01279 70th percentileScored 2026-11-07
Fix Fixed Rancher (SUSE): 2.14.2, 2.13.6, 2.12.10 +2github.com/rancher/rancher (Go): 2.14.2, 2.13.6, 2.12.10 +3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | Rancher | 2.14.0 to before 2.14.2; 2.13.0 to before 2.13.6; 2.12.0 to before 2.12.10; 2.11.0 to before 2.11.14; 2.10.0 to before 2.10.12 | 2.14.2, 2.13.6, 2.12.10, 2.11.14, 2.10.12 | Patch available | CNA |
| — | github.com/rancher/rancher (Go) | 2.14.0 to before 2.14.2 | 2.14.2 | Patch available | GHSA-mhc6-2gfq-xx62 |
| — | github.com/rancher/rancher (Go) | 2.13.0 to before 2.13.6 | 2.13.6 | Patch available | GHSA-mhc6-2gfq-xx62 |
| — | github.com/rancher/rancher (Go) | 2.12.0 to before 2.12.10 | 2.12.10 | Patch available | GHSA-mhc6-2gfq-xx62 |
| — | github.com/rancher/rancher (Go) | 2.11.0 to before 2.11.14 | 2.11.14 | Patch available | GHSA-mhc6-2gfq-xx62 |
| — | github.com/rancher/rancher (Go) | 2.10.0 to before 2.10.12 | 2.10.12 | Patch available | GHSA-mhc6-2gfq-xx62 |
| — | github.com/rancher/rancher (Go) | before 0.0.0-20260617231817-2aa77eb283e7 | 0.0.0-20260617231817-2aa77eb283e7 | Patch available | GHSA-mhc6-2gfq-xx62 |
- Rancher VendorSUSE Affected 2.14.0 to before 2.14.2; 2.13.0 to before 2.13.6; 2.12.0 to before 2.12.10; 2.11.0 to before 2.11.14; 2.10.0 to before 2.10.12 Fixed in 2.14.2, 2.13.6, 2.12.10, 2.11.14, 2.10.12 Patch available CNA
- github.com/rancher/rancher (Go) Vendor— Affected 2.14.0 to before 2.14.2 Fixed in 2.14.2 Patch available GHSA-mhc6-2gfq-xx62
- github.com/rancher/rancher (Go) Vendor— Affected 2.13.0 to before 2.13.6 Fixed in 2.13.6 Patch available GHSA-mhc6-2gfq-xx62
- github.com/rancher/rancher (Go) Vendor— Affected 2.12.0 to before 2.12.10 Fixed in 2.12.10 Patch available GHSA-mhc6-2gfq-xx62
- github.com/rancher/rancher (Go) Vendor— Affected 2.11.0 to before 2.11.14 Fixed in 2.11.14 Patch available GHSA-mhc6-2gfq-xx62
- github.com/rancher/rancher (Go) Vendor— Affected 2.10.0 to before 2.10.12 Fixed in 2.10.12 Patch available GHSA-mhc6-2gfq-xx62
- github.com/rancher/rancher (Go) Vendor— Affected before 0.0.0-20260617231817-2aa77eb283e7 Fixed in 0.0.0-20260617231817-2aa77eb283e7 Patch available GHSA-mhc6-2gfq-xx62
Remediation
- Fix · CNA Rancher (SUSE) Fixed in 2.14.2, 2.13.6, 2.12.10, 2.11.14, 2.10.12
- Fix · GHSA-mhc6-2gfq-xx62 github.com/rancher/rancher (Go) Fixed in 2.14.2 Advisory →
- Fix · GHSA-mhc6-2gfq-xx62 github.com/rancher/rancher (Go) Fixed in 2.13.6 Advisory →
- Fix · GHSA-mhc6-2gfq-xx62 github.com/rancher/rancher (Go) Fixed in 2.12.10 Advisory →
- Fix · GHSA-mhc6-2gfq-xx62 github.com/rancher/rancher (Go) Fixed in 2.11.14 Advisory →
- Fix · GHSA-mhc6-2gfq-xx62 github.com/rancher/rancher (Go) Fixed in 2.10.12 Advisory →
- Fix · GHSA-mhc6-2gfq-xx62 github.com/rancher/rancher (Go) Fixed in 0.0.0-20260617231817-2aa77eb283e7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-44939
- 2026-10-03 Alias added: GHSA-mhc6-2gfq-xx62
- 2026-11-03 CISA SSVC decision points changed
References
More SUSE vulnerabilities
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-44939 · CVE Program
- CVE-2026-44939 · NVD
- FIRST EPSS
- GHSA-mhc6-2gfq-xx62 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences