Nextcloud: Cross-Account Calendar Takeover via Unauthorized Group-Member-Set Update
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-639.
Summary
Nextcloud is an open source content collaboration platform. In Nextcloud Server from versions 32.0.0 to before 32.0.9, and 33.0.0 to before 33.0.3, with the knowledge of other users’ principal URL an attacker could possibly send a request to gain full access to their calendar. Therefore, the attacker must be an authenticated user. This is because of improper authorization controls in the backend of the calendar. If the attacker had access to the calendar, they would be able to view and modify it. It is recommended that the Nextcloud Server is upgraded to 33.0.3 or 32.0.9. It is recommended that the Nextcloud Enterprise Server is upgraded to 33.0.3, 32.0.9, 31.0.14.5, 30.0.17.9, 29.0.16.16, 28.0.14.17, 27.1.11.26, 26.0.13.26, 25.0.13.29, 24.0.12.34, 23.0.12.35, 22.2.10.39, or 21.0.9.23
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| nextcloud | security-advisories | 32.0.0 to before 32.0.9; 33.0.0 to before 33.0.3 | 32.0.9, 33.0.3 | Patch available | CNA |
- security-advisories Vendornextcloud Affected 32.0.0 to before 32.0.9; 33.0.0 to before 33.0.3 Fixed in 32.0.9, 33.0.3 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:-:*:*:* | 32.0.0 to before 32.0.9; 33.0.0 to before 33.0.3 | Vulnerable | nextcloud |
| cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* | 21.0.0 to before 21.0.9.23; 22.0.0 to before 22.2.10.39; 23.0.0 to before 23.0.12.35; 24.0.0 to before 24.0.12.34; 25.0.0 to before 25.0.13.29; 26.0.0 to before 26.0.13.26; 27.0.0 to before 27.1.11.26; 28.0.0 to before 28.0.14.17; 29.0.0 to before 29.0.16.16; 30.0.0 to before 30.0.17.9; 31.0.0 to before 31.0.14.5; 32.0.0 to before 32.0.9; 33.0.0 to before 33.0.3 | Vulnerable | nextcloud |
- cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:-:*:*:* Versions 32.0.0 to before 32.0.9; 33.0.0 to before 33.0.3 Vulnerable ·nextcloud
- cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* Versions 21.0.0 to before 21.0.9.23; 22.0.0 to before 22.2.10.39; 23.0.0 to before 23.0.12.35; 24.0.0 to before 24.0.12.34; 25.0.0 to before 25.0.13.29; 26.0.0 to before 26.0.13.26; 27.0.0 to before 27.1.11.26; 28.0.0 to before 28.0.14.17; 29.0.0 to before 29.0.16.16; 30.0.0 to before 30.0.17.9; 31.0.0 to before 31.0.14.5; 32.0.0 to before 32.0.9; 33.0.0 to before 33.0.3 Vulnerable ·nextcloud
Remediation
- Fix · CNA security-advisories (nextcloud) Fixed in 32.0.9, 33.0.3
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-45281
References
More Nextcloud Server vulnerabilities
- TI-2023-20855 Users can delete external storage mount points CVSS 3.1HIGH 7.7
- TI-2023-11091 Nextcloud download permissions can be changed by resharer CVSS 3.1HIGH 7.5
- TI-2023-10624 Nextcloud Server vulnerable to SSRF via filter bypass due to lax checking on IPs CVSS 3.1MEDIUM 5.3
- TI-2025-37238 Cross-site scripting in Nextcloud CVSS 3.1MEDIUM 6.4
- TI-2023-11086 nextcloud vulnerable to Uncontrolled Resource Consumption CVSS 3.1MEDIUM 6.5
- TI-2022-18738 Exception logging in Sharepoint app reveals clear-text connection details CVSS 3.1MEDIUM 6.5
Sources
- CVE-2026-45281 · CVE Program
- CVE-2026-45281 · NVD
- FIRST EPSS
- CVE-2026-45281 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences