Kirby: Cross-site scripting (XSS) from links in KirbyTags and image blocks in the site frontend
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Kirby is an open-source content management system. In versions prior to 4.9.1 and 5.4.1, the underlying URL methods for the KirbyTags and image blocks components did not filter out malicious URL values that resolve to script execution. The vulnerability affects four first-party Kirby renderers that produce `<a href="…">` output from editor-supplied field values: the (`link: …)` KirbyTag, the `link`: parameter of the `(image: …)` KirbyTag when it does not resolve to a known file or `self`, the `link` field of the built-in image block, and the HTML importer for the `blocks` field (which accepted the same malicious input as the image block `link` field). While simple `avascript:` URLs were already deactivated by treating them as a relative path and prepending a single slash to the URL, the use of URLs of the format `javascript://x%0A…` bypasses this protection. The `vbscript:`, `data:`, `livescript:`, `mocha:` and `jar:` schemes are affected by the same underlying gap. This issue has been fixed in versions 4.9.1 and 5.4.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| getkirby | kirby | before 4.9.1; 5.0.0 to before 5.4.1 | 4.9.1, 5.4.1 | Patch available | CNA |
| — | getkirby/cms (Packagist) | before 4.9.1 | 4.9.1 | Patch available | GHSA-qvjf-922g-pj44 |
| — | getkirby/cms (Packagist) | 5.0.0 to before 5.4.1 | 5.4.1 | Patch available | GHSA-qvjf-922g-pj44 |
- kirby Vendorgetkirby Affected before 4.9.1; 5.0.0 to before 5.4.1 Fixed in 4.9.1, 5.4.1 Patch available CNA
- getkirby/cms (Packagist) Vendor— Affected before 4.9.1 Fixed in 4.9.1 Patch available GHSA-qvjf-922g-pj44
- getkirby/cms (Packagist) Vendor— Affected 5.0.0 to before 5.4.1 Fixed in 5.4.1 Patch available GHSA-qvjf-922g-pj44
Remediation
- Fix · CNA kirby (getkirby) Fixed in 4.9.1, 5.4.1
- Fix · GHSA-qvjf-922g-pj44 getkirby/cms (Packagist) Fixed in 4.9.1 Advisory →
- Fix · GHSA-qvjf-922g-pj44 getkirby/cms (Packagist) Fixed in 5.4.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-45368
- 2026-10-03 Alias added: GHSA-qvjf-922g-pj44
References
More getkirby vulnerabilities
- TI-2024-17440 An arbitrary file upload vulnerability in the Profile Image module of Kirby CMS v4.1.0… CVSS 3.1HIGH 8.8
- TI-2024-17439 An HTML injection vulnerability exists in the Edit Content Layout module of Kirby CMS… CVSS 3.1HIGH 7.1
- TI-2026-23396 Kirby CMS through 5.1.4 allows an authenticated user with 'Editor' permissions to cause a… CVSS 3.1MEDIUM 6.5
- TI-2024-17441 A stored cross-site scripting (XSS) vulnerability in the Edit Content Layout module of… CVSS 3.1MEDIUM 6.1
- TI-2018-10413 An issue was discovered in Kirby 2.5.12. CVSS 3.1MEDIUM 5.4
- TI-2024-17438 Kirby CMS v4.1.0 was discovered to contain a reflected self-XSS vulnerability via the URL parameter. CVSS 3.1MEDIUM 4.7
Sources
- CVE-2026-45368 · CVE Program
- CVE-2026-45368 · NVD
- FIRST EPSS
- GHSA-qvjf-922g-pj44 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences