Composer: Github Actions issued GITHUB_TOKEN disclosure in GitHub Actions logs
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Composer is a dependency Manager for the PHP language. Prior to 1.10.28, 2.2.28, and 2.9.8, Composer\IO\BaseIO::loadConfiguration() validates GitHub OAuth tokens with the regex ^[.A-Za-z0-9_]+$ and interpolates rejected tokens into an UnexpectedValueException; GitHub Actions GITHUB_TOKEN values using the ghs_<id>_<base64url-JWT> format can contain -, fail validation, and be disclosed to stderr or CI logs. This issue is fixed in versions 1.10.28, 2.2.28, and 2.9.8.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| composer | composer | 1.0 to before 1.10.28; 2.0.0 to before 2.2.28; 2.3.0 to before 2.9.8 | 1.10.28, 2.2.28, 2.9.8 | Patch available | CNA |
| — | composer/composer (Packagist) | 2.3.0 to before 2.9.8 | 2.9.8 | Patch available | GHSA-f9f8-rm49-7jv2 |
| — | composer/composer (Packagist) | 2.0.0 to before 2.2.28 | 2.2.28 | Patch available | GHSA-f9f8-rm49-7jv2 |
| — | composer/composer (Packagist) | 1.0 to before 1.10.28 | 1.10.28 | Patch available | GHSA-f9f8-rm49-7jv2 |
- composer Vendorcomposer Affected 1.0 to before 1.10.28; 2.0.0 to before 2.2.28; 2.3.0 to before 2.9.8 Fixed in 1.10.28, 2.2.28, 2.9.8 Patch available CNA
- composer/composer (Packagist) Vendor— Affected 2.3.0 to before 2.9.8 Fixed in 2.9.8 Patch available GHSA-f9f8-rm49-7jv2
- composer/composer (Packagist) Vendor— Affected 2.0.0 to before 2.2.28 Fixed in 2.2.28 Patch available GHSA-f9f8-rm49-7jv2
- composer/composer (Packagist) Vendor— Affected 1.0 to before 1.10.28 Fixed in 1.10.28 Patch available GHSA-f9f8-rm49-7jv2
Remediation
- Fix · CNA composer (composer) Fixed in 1.10.28, 2.2.28, 2.9.8
- Fix · GHSA-f9f8-rm49-7jv2 composer/composer (Packagist) Fixed in 2.9.8 Advisory →
- Fix · GHSA-f9f8-rm49-7jv2 composer/composer (Packagist) Fixed in 2.2.28 Advisory →
- Fix · GHSA-f9f8-rm49-7jv2 composer/composer (Packagist) Fixed in 1.10.28 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat Hardened Images
Timeline
- 2026-10-02 Threatist record created from CVE-2026-45793
- 2026-10-03 Alias added: GHSA-f9f8-rm49-7jv2
- 2026-10-29 Affected versions changed · Red Hat
- 2026-10-29 CVSS score added · Red Hat
References
Other 11
- https://github.com/composer/composer/security/advisories/GHSA-f9f8-rm49-7jv2
- https://github.com/composer/composer/pull/12853
- https://github.com/composer/composer/pull/12855
- https://github.com/composer/composer/commit/3f5e7f9fbfa541137d6d1d5643ec3b718e9d5039
- https://github.com/composer/composer/commit/65e6390c49f1a11cd8b660d81822086db51fe2d1
- https://github.com/composer/composer/commit/e66c8fdb7ff5409bd2f358c5f194038e49e93714
- https://github.com/composer/composer/releases/tag/1.10.28
- https://github.com/composer/composer/releases/tag/2.2.28
- https://github.com/composer/composer/releases/tag/2.9.8
- https://github.com/FriendsOfPHP/security-advisories/blob/master/composer/composer/CVE-2026-45793.yaml
- https://github.com/composer/composer
More composer vulnerabilities
- TI-2015-06892 Composer before 2016-02-10 allows cache poisoning from other projects built on the same… CVSS 3.1HIGH 8.8
- TI-2021-17955 Command injection in composer on Windows CVSS 3.1CRITICAL 9.8
- TI-2024-23311 Composer vulnerable to command injection via malicious git/hg branch names CVSS 3.1HIGH 8.8
- TI-2021-10185 Code injection in composer CVSS 3.1HIGH 8.8
- TI-2022-08641 Missing input validation can lead to command execution in composer CVSS 3.1HIGH 8.8
- TI-2026-29055 Composer has Command Injection via Malicious Perforce Reference CVSS 3.1HIGH 8.8
Sources
- CVE-2026-45793 · CVE Program
- CVE-2026-45793 · NVD
- FIRST EPSS
- GHSA-f9f8-rm49-7jv2 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-45793 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences