ipvs: skip ipv6 extension headers for csum checks
Priority LOW 24Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: ipvs: skip ipv6 extension headers for csum checks Protocol checksum validation fails for IPv6 if there are extension headers before the protocol header. iph->len already contains its offset, so use it to fix the problem.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00164 5th percentileScored 2026-11-07
Fix Fixed Linux (Linux): 5.10.259, 5.15.210, 6.1.176 +5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 2.6.28 and later | 5.10.259, 5.15.210, 6.1.176, 6.6.143, 6.12.94, 6.18.36, 6.19.4, 7.0 | Patch available | CNA |
- Linux VendorLinux Affected 2.6.28 and later Fixed in 5.10.259, 5.15.210, 6.1.176, 6.6.143, 6.12.94, 6.18.36, 6.19.4, 7.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 2.6.28 to before 5.10.259; 5.11 to before 5.15.210; 5.16 to before 6.1.176; 6.2 to before 6.6.143; 6.7 to before 6.12.94; 6.13 to before 6.18.36; 6.19 to before 6.19.4 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 2.6.28 to before 5.10.259; 5.11 to before 5.15.210; 5.16 to before 6.1.176; 6.2 to before 6.6.143; 6.7 to before 6.12.94; 6.13 to before 6.18.36; 6.19 to before 6.19.4 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.10.259, 5.15.210, 6.1.176, 6.6.143, 6.12.94, 6.18.36, 6.19.4, 7.0
Vendor assessments
Red Hat
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2026-45850
- 2026-10-03 Alias added: GHSA-3j9q-258h-4v38
- 2026-11-06 CISA SSVC decision points changed
References
Patch 8
- https://git.kernel.org/stable/c/0bf92a90bf05ecafe52e92d5bc15a585021a64ac
- https://git.kernel.org/stable/c/54add3b7d3c154ca89ef5bac2582b0ed1a3a15d5
- https://git.kernel.org/stable/c/768f665f3685b455ed686370ed7ccb852a125a3b
- https://git.kernel.org/stable/c/9aa7edc1347b98774e5167ca34e5b8aa6083bde7
- https://git.kernel.org/stable/c/d643c1ec80b70508f54dac12179e36920e2c00de
- https://git.kernel.org/stable/c/cdce1e797addab72393c0dfee31aaca41ef7d937
- https://git.kernel.org/stable/c/a3ca27762ce8476b4fbf9b2a8f5cb74c38e483e4
- https://git.kernel.org/stable/c/05cfe9863ef049d98141dc2969eefde72fb07625
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2026-45850 · CVE Program
- CVE-2026-45850 · NVD
- FIRST EPSS
- GHSA-3j9q-258h-4v38 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-45850 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences