power: supply: wm97xx: Fix NULL pointer dereference in power_supply_changed()
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-476.
Summary
In the Linux kernel, the following vulnerability has been resolved: power: supply: wm97xx: Fix NULL pointer dereference in power_supply_changed() In `probe()`, `request_irq()` is called before allocating/registering a `power_supply` handle. If an interrupt is fired between the call to `request_irq()` and `power_supply_register()`, the `power_supply` handle will be used uninitialized in `power_supply_changed()` in `wm97xx_bat_update()` (triggered from the interrupt handler). This will lead to a `NULL` pointer dereference since Fix this racy `NULL` pointer dereference by making sure the IRQ is requested _after_ the registration of the `power_supply` handle. Since the IRQ is the last thing requests in the `probe()` now, remove the error path for freeing it. Instead add one for unregistering the `power_supply` handle when IRQ request fails.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 2.6.32 and later | 5.10.252, 5.15.202, 6.1.165, 6.6.128, 6.12.75, 6.18.14, 6.19.4, 7.0 | Patch available | CNA |
- Linux VendorLinux Affected 2.6.32 and later Fixed in 5.10.252, 5.15.202, 6.1.165, 6.6.128, 6.12.75, 6.18.14, 6.19.4, 7.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 2.6.32 to before 5.10.252; 5.11 to before 5.15.202; 5.16 to before 6.1.165; 6.2 to before 6.6.128; 6.7 to before 6.12.75; 6.13 to before 6.18.14; 6.19 to before 6.19.4 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 2.6.32 to before 5.10.252; 5.11 to before 5.15.202; 5.16 to before 6.1.165; 6.2 to before 6.6.128; 6.7 to before 6.12.75; 6.13 to before 6.18.14; 6.19 to before 6.19.4 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.10.252, 5.15.202, 6.1.165, 6.6.128, 6.12.75, 6.18.14, 6.19.4, 7.0
Vendor assessments
Red Hat
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2026-45869
- 2026-10-03 Alias added: GHSA-7c8r-gw7p-h2xw
References
Patch 8
- https://git.kernel.org/stable/c/3d7b5391bb95505b3581c1fb77150c467ab92864
- https://git.kernel.org/stable/c/438f9a303ea8b55162b2d5376490c2ab3ec165a0
- https://git.kernel.org/stable/c/9b7d77cb046b4487e8e511e04e62b6f416ce845c
- https://git.kernel.org/stable/c/86183153c299e8bb1839e717286d6c6f39508a59
- https://git.kernel.org/stable/c/93bdf715d33cf5ee01c58e8546c2469c71ce082a
- https://git.kernel.org/stable/c/c0def811ad8d642dca9b6d31a198cc39f5f90837
- https://git.kernel.org/stable/c/dfaf235d5a6b60cbf115a14a656946303ad007b7
- https://git.kernel.org/stable/c/39fe0eac6d755ef215026518985fcf8de9360e9e
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2026-45869 · CVE Program
- CVE-2026-45869 · NVD
- FIRST EPSS
- GHSA-7c8r-gw7p-h2xw · GitHub Advisory Database · CC BY 4.0
- CVE-2026-45869 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences