Read the docs
TI-2026-33870 Aliases CVE-2026-46146GHSA-pvph-jwxq-qcxw

ALSA: usb-audio: Avoid potential endless loop in convert_chmap_v3()

Priority LOW 24CWE-835Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Partial Red Hat: 5 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-835.

Summary

In the Linux kernel, the following vulnerability has been resolved: ALSA: usb-audio: Avoid potential endless loop in convert_chmap_v3() The convert_chmap_v3() has a loop with its increment size of cs_desc->wLength, but we forgot to validate cs_desc->wLength itself, which may lead to potential endless loop by a malformed descriptor. Add a proper size check to abort the loop for plugging the hole.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00131 2nd percentileScored 2026-11-07
Fix Partial Linux (Linux): 5.10.258, 5.15.209, 6.1.175 +8Red Hat: 5 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
LinuxLinux5.10.241 to before 5.10.258; 5.15.190 to before 5.15.209; 6.1.149 to before 6.1.175; 6.6.103 to before 6.6.140; 6.12.43 to before 6.12.88; 5.4.297 to before 5.5; 6.15.11 to before 6.16; 6.16.2 to before 6.175.10.258, 5.15.209, 6.1.175, 6.6.140, 6.12.88, 5.5, 6.16, 6.17Patch availableCNA
LinuxLinux6.17 and later5.10.258, 5.15.209, 6.1.175, 6.6.140, 6.12.88, 6.18.30, 7.0.7, 7.1Patch availableCNA
  • Linux VendorLinux Affected 5.10.241 to before 5.10.258; 5.15.190 to before 5.15.209; 6.1.149 to before 6.1.175; 6.6.103 to before 6.6.140; 6.12.43 to before 6.12.88; 5.4.297 to before 5.5; 6.15.11 to before 6.16; 6.16.2 to before 6.17 Fixed in 5.10.258, 5.15.209, 6.1.175, 6.6.140, 6.12.88, 5.5, 6.16, 6.17 Patch available CNA
  • Linux VendorLinux Affected 6.17 and later Fixed in 5.10.258, 5.15.209, 6.1.175, 6.6.140, 6.12.88, 6.18.30, 7.0.7, 7.1 Patch available CNA

CPE configurations NVD · 9

CPEVersionsRoleVendor
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*5.4.297 to before 5.5; 5.10.241 to before 5.10.258; 5.15.190 to before 5.15.209; 6.1.149 to before 6.1.175; 6.6.103 to before 6.6.140; 6.12.43 to before 6.12.88; 6.15.11 to before 6.16; 6.16.2 to before 6.17; 6.17.1 to before 6.18.30; 6.19 to before 7.0.7VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.17:-:*:*:*:*:*:*6.17VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.17:rc2:*:*:*:*:*:*6.17 rc2VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.17:rc3:*:*:*:*:*:*6.17 rc3VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.17:rc4:*:*:*:*:*:*6.17 rc4VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.17:rc5:*:*:*:*:*:*6.17 rc5VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.17:rc6:*:*:*:*:*:*6.17 rc6VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.17:rc7:*:*:*:*:*:*6.17 rc7VulnerableLinux
cpe:2.3:o:linux:linux_kernel:7.1:rc1:*:*:*:*:*:*7.1 rc1VulnerableLinux
  • cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.4.297 to before 5.5; 5.10.241 to before 5.10.258; 5.15.190 to before 5.15.209; 6.1.149 to before 6.1.175; 6.6.103 to before 6.6.140; 6.12.43 to before 6.12.88; 6.15.11 to before 6.16; 6.16.2 to before 6.17; 6.17.1 to before 6.18.30; 6.19 to before 7.0.7 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.17:-:*:*:*:*:*:* Versions 6.17 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.17:rc2:*:*:*:*:*:* Versions 6.17 rc2 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.17:rc3:*:*:*:*:*:* Versions 6.17 rc3 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.17:rc4:*:*:*:*:*:* Versions 6.17 rc4 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.17:rc5:*:*:*:*:*:* Versions 6.17 rc5 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.17:rc6:*:*:*:*:*:* Versions 6.17 rc6 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.17:rc7:*:*:*:*:*:* Versions 6.17 rc7 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:7.1:rc1:*:*:*:*:*:* Versions 7.1 rc1 Vulnerable ·Linux

Remediation

  • Fix · CNA Linux (Linux) Fixed in 5.10.258, 5.15.209, 6.1.175, 6.6.140, 6.12.88, 5.5, 6.16, 6.17
  • Fix · CNA Linux (Linux) Fixed in 5.10.258, 5.15.209, 6.1.175, 6.6.140, 6.12.88, 6.18.30, 7.0.7, 7.1

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 10AffectedNo fix yet: Fix deferred
Red Hat Enterprise Linux 6AffectedNo fix planned: Out of support scope
Red Hat Enterprise Linux 7AffectedNo fix yet: Fix deferred
Red Hat Enterprise Linux 8AffectedNo fix yet: Fix deferred
Red Hat Enterprise Linux 9AffectedNo fix yet: Fix deferred

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-46146
  2. 2026-10-03 Alias added: GHSA-pvph-jwxq-qcxw
  3. 2026-11-06 CISA SSVC decision points changed

References

  • TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
  • TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
  • TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
  • TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
  • TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
See all 15278 →

Sources