spi: mpc52xx: fix use-after-free on unbind
Priority LOW 33CWE-416Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-416 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: spi: mpc52xx: fix use-after-free on unbind The state machine work is scheduled by the interrupt handler and therefore needs to be cancelled after disabling interrupts to avoid a potential use-after-free.
Why it matters now
EPSS 0.00135 2nd percentileScored 2026-11-07
Fix Fixed Linux (Linux): 5.10.258, 5.15.209, 6.1.175 +6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.10.231 to before 5.10.258; 5.15.174 to before 5.15.209; 6.1.120 to before 6.1.175; 6.6.66 to before 6.6.140; 6.12.5 to before 6.12.90; 5.4.287 to before 5.5 | 5.10.258, 5.15.209, 6.1.175, 6.6.140, 6.12.90, 5.5 | Patch available | CNA |
| Linux | Linux | 6.13 and later | 5.10.258, 5.15.209, 6.1.175, 6.6.140, 6.12.90, 6.18.32, 7.0.9, 7.1 | Patch available | CNA |
- Linux VendorLinux Affected 5.10.231 to before 5.10.258; 5.15.174 to before 5.15.209; 6.1.120 to before 6.1.175; 6.6.66 to before 6.6.140; 6.12.5 to before 6.12.90; 5.4.287 to before 5.5 Fixed in 5.10.258, 5.15.209, 6.1.175, 6.6.140, 6.12.90, 5.5 Patch available CNA
- Linux VendorLinux Affected 6.13 and later Fixed in 5.10.258, 5.15.209, 6.1.175, 6.6.140, 6.12.90, 6.18.32, 7.0.9, 7.1 Patch available CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.4.287 to before 5.5; 5.10.231 to before 5.10.258; 5.15.174 to before 5.15.209; 6.1.120 to before 6.1.175; 6.6.66 to before 6.6.140; 6.12.5 to before 6.12.90; 6.13.1 to before 6.18.32; 6.19 to before 7.0.9 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.13:-:*:*:*:*:*:* | 6.13 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.13:rc2:*:*:*:*:*:* | 6.13 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.13:rc3:*:*:*:*:*:* | 6.13 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.13:rc4:*:*:*:*:*:* | 6.13 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.13:rc5:*:*:*:*:*:* | 6.13 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.13:rc6:*:*:*:*:*:* | 6.13 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.13:rc7:*:*:*:*:*:* | 6.13 rc7 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.4.287 to before 5.5; 5.10.231 to before 5.10.258; 5.15.174 to before 5.15.209; 6.1.120 to before 6.1.175; 6.6.66 to before 6.6.140; 6.12.5 to before 6.12.90; 6.13.1 to before 6.18.32; 6.19 to before 7.0.9 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.13:-:*:*:*:*:*:* Versions 6.13 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.13:rc2:*:*:*:*:*:* Versions 6.13 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.13:rc3:*:*:*:*:*:* Versions 6.13 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.13:rc4:*:*:*:*:*:* Versions 6.13 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.13:rc5:*:*:*:*:*:* Versions 6.13 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.13:rc6:*:*:*:*:*:* Versions 6.13 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.13:rc7:*:*:*:*:*:* Versions 6.13 rc7 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.10.258, 5.15.209, 6.1.175, 6.6.140, 6.12.90, 5.5
- Fix · CNA Linux (Linux) Fixed in 5.10.258, 5.15.209, 6.1.175, 6.6.140, 6.12.90, 6.18.32, 7.0.9, 7.1
Vendor assessments
Red Hat
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2026-46219
- 2026-10-03 Alias added: GHSA-993q-fvmm-5hv9
References
Patch 8
- https://git.kernel.org/stable/c/ac8316c896c79f32c1d0a38cb41fd2b14cf8112e
- https://git.kernel.org/stable/c/ed929d40963073f23cfb50219ccbcc6e0c3ea641
- https://git.kernel.org/stable/c/0944b20e9dfa2917bd70eb5b301cbb67fe54a718
- https://git.kernel.org/stable/c/bb6b50f709c5a01906ff72a07fdc070bb3357188
- https://git.kernel.org/stable/c/ee52da0dd83ebcd89ecbbe2660c57b15a25489f2
- https://git.kernel.org/stable/c/6c3e413919a12627d04a31a4a5fccb9fc129bb02
- https://git.kernel.org/stable/c/bbcd6dd8e9f264440eaf6167382bf404911c1c46
- https://git.kernel.org/stable/c/706b3dc2ac7a998c55e14b3fd2e8f934c367e6e0
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2026-46219 · CVE Program
- CVE-2026-46219 · NVD
- FIRST EPSS
- GHSA-993q-fvmm-5hv9 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-46219 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences