leds: qcom-lpg: Check for array overflow when selecting the high resolution
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: leds: qcom-lpg: Check for array overflow when selecting the high resolution When selecting the high resolution values from the array, FIELD_GET() is used to pull from a 3 bit register, yet the array being indexed has only 5 values in it. Odds are the hardware is sane, but just to be safe, properly check before just overflowing and reading random data and then setting up chip values based on that.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 6.4 and later | 6.6.140, 6.12.86, 6.18.27, 7.0.4, 7.1 | Patch available | CNA |
- Linux VendorLinux Affected 6.4 and later Fixed in 6.6.140, 6.12.86, 6.18.27, 7.0.4, 7.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 6.4 to before 6.6.140; 6.7 to before 6.12.86; 6.13 to before 6.18.27; 6.19 to before 7.0.4 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 6.4 to before 6.6.140; 6.7 to before 6.12.86; 6.13 to before 6.18.27; 6.19 to before 7.0.4 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.6.140, 6.12.86, 6.18.27, 7.0.4, 7.1
Vendor assessments
Red Hat
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2026-46286
- 2026-10-03 Alias added: GHSA-5439-prm7-qcx4
References
Patch 5
- https://git.kernel.org/stable/c/28a2e047d03721e0517c67ee726eaa6621c30e5f
- https://git.kernel.org/stable/c/36ce3094dc50598f38fd961b46688cd533940efc
- https://git.kernel.org/stable/c/438e357b3cc6cd6900df271e4bc567bfe1142281
- https://git.kernel.org/stable/c/f67a24e75d3251ba42538738120b6b659c0dca7d
- https://git.kernel.org/stable/c/d45963a93c1495e9f1338fde91d0ebba8fd22474
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2026-46286 · CVE Program
- CVE-2026-46286 · NVD
- FIRST EPSS
- GHSA-5439-prm7-qcx4 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-46286 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences