Angular: SSRF via Hostname Hijacking in @angular/platform-server
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat.
Summary
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-next.12, 21.2.13, 20.3.21, and 19.2.22, a Server-Side Request Forgery (SSRF) vulnerability exists in @angular/platform-server. The issue stems from how the server-side rendering (SSR) engine processes the request URL provided to the rendering entry points. When an absolute-form URL (e.g., http://evil.com) is passed to the rendering engine, the internal ServerPlatformLocation can be manipulated into adopting the attacker-controlled domain as the "current" hostname. Consequently, any relative HttpClient requests or PlatformLocation.hostname references are redirected to the attacker controlled server, potentially exposing internal APIs or metadata services. This vulnerability is fixed in 22.0.0-next.12, 21.2.13, 20.3.21, and 19.2.22.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| angular | angular | 22.0.0-next.0 to before 22.0.0-next.12; 21.0.0-next.0 to before 21.2.13; 20.0.0-next.0 to before 20.3.21; 19.0.0-next.0 to before 19.2.22; up to 18.2.14 | 22.0.0-next.12, 21.2.13, 20.3.21, 19.2.22 | Patch available | CNA |
| — | @angular/platform-server (npm) | 22.0.0-next.0 to before 22.0.0-next.12 | 22.0.0-next.12 | Patch available | GHSA-rfh7-fxqc-q52v |
| — | @angular/platform-server (npm) | 21.0.0-next.0 to before 21.2.13 | 21.2.13 | Patch available | GHSA-rfh7-fxqc-q52v |
| — | @angular/platform-server (npm) | 20.0.0-next.0 to before 20.3.21 | 20.3.21 | Patch available | GHSA-rfh7-fxqc-q52v |
| — | @angular/platform-server (npm) | 19.0.0-next.0 to before 19.2.22 | 19.2.22 | Patch available | GHSA-rfh7-fxqc-q52v |
| — | @angular/platform-server (npm) | up to 18.2.14 | — | No fix listed | GHSA-rfh7-fxqc-q52v |
- angular Vendorangular Affected 22.0.0-next.0 to before 22.0.0-next.12; 21.0.0-next.0 to before 21.2.13; 20.0.0-next.0 to before 20.3.21; 19.0.0-next.0 to before 19.2.22; up to 18.2.14 Fixed in 22.0.0-next.12, 21.2.13, 20.3.21, 19.2.22 Patch available CNA
- @angular/platform-server (npm) Vendor— Affected 22.0.0-next.0 to before 22.0.0-next.12 Fixed in 22.0.0-next.12 Patch available GHSA-rfh7-fxqc-q52v
- @angular/platform-server (npm) Vendor— Affected 21.0.0-next.0 to before 21.2.13 Fixed in 21.2.13 Patch available GHSA-rfh7-fxqc-q52v
- @angular/platform-server (npm) Vendor— Affected 20.0.0-next.0 to before 20.3.21 Fixed in 20.3.21 Patch available GHSA-rfh7-fxqc-q52v
- @angular/platform-server (npm) Vendor— Affected 19.0.0-next.0 to before 19.2.22 Fixed in 19.2.22 Patch available GHSA-rfh7-fxqc-q52v
- @angular/platform-server (npm) Vendor— Affected up to 18.2.14 Fixed in — No fix listed GHSA-rfh7-fxqc-q52v
CPE configurations NVD · 13
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:angular:angular:*:*:*:*:*:node.js:*:* | up to 18.2.14; 19.0.0 to before 19.2.22; 20.0.0 to before 20.3.21; 21.0.0 to before 21.2.13 | Vulnerable | angular |
| cpe:2.3:a:angular:angular:22.0.0:next0:*:*:*:node.js:*:* | 22.0.0 next0 | Vulnerable | angular |
| cpe:2.3:a:angular:angular:22.0.0:next1:*:*:*:node.js:*:* | 22.0.0 next1 | Vulnerable | angular |
| cpe:2.3:a:angular:angular:22.0.0:next10:*:*:*:node.js:*:* | 22.0.0 next10 | Vulnerable | angular |
| cpe:2.3:a:angular:angular:22.0.0:next11:*:*:*:node.js:*:* | 22.0.0 next11 | Vulnerable | angular |
| cpe:2.3:a:angular:angular:22.0.0:next2:*:*:*:node.js:*:* | 22.0.0 next2 | Vulnerable | angular |
| cpe:2.3:a:angular:angular:22.0.0:next3:*:*:*:node.js:*:* | 22.0.0 next3 | Vulnerable | angular |
| cpe:2.3:a:angular:angular:22.0.0:next4:*:*:*:node.js:*:* | 22.0.0 next4 | Vulnerable | angular |
| cpe:2.3:a:angular:angular:22.0.0:next5:*:*:*:node.js:*:* | 22.0.0 next5 | Vulnerable | angular |
| cpe:2.3:a:angular:angular:22.0.0:next6:*:*:*:node.js:*:* | 22.0.0 next6 | Vulnerable | angular |
- cpe:2.3:a:angular:angular:*:*:*:*:*:node.js:*:* Versions up to 18.2.14; 19.0.0 to before 19.2.22; 20.0.0 to before 20.3.21; 21.0.0 to before 21.2.13 Vulnerable ·angular
- cpe:2.3:a:angular:angular:22.0.0:next0:*:*:*:node.js:*:* Versions 22.0.0 next0 Vulnerable ·angular
- cpe:2.3:a:angular:angular:22.0.0:next1:*:*:*:node.js:*:* Versions 22.0.0 next1 Vulnerable ·angular
- cpe:2.3:a:angular:angular:22.0.0:next10:*:*:*:node.js:*:* Versions 22.0.0 next10 Vulnerable ·angular
- cpe:2.3:a:angular:angular:22.0.0:next11:*:*:*:node.js:*:* Versions 22.0.0 next11 Vulnerable ·angular
- cpe:2.3:a:angular:angular:22.0.0:next2:*:*:*:node.js:*:* Versions 22.0.0 next2 Vulnerable ·angular
- cpe:2.3:a:angular:angular:22.0.0:next3:*:*:*:node.js:*:* Versions 22.0.0 next3 Vulnerable ·angular
- cpe:2.3:a:angular:angular:22.0.0:next4:*:*:*:node.js:*:* Versions 22.0.0 next4 Vulnerable ·angular
- cpe:2.3:a:angular:angular:22.0.0:next5:*:*:*:node.js:*:* Versions 22.0.0 next5 Vulnerable ·angular
- cpe:2.3:a:angular:angular:22.0.0:next6:*:*:*:node.js:*:* Versions 22.0.0 next6 Vulnerable ·angular
Remediation
- Fix · CNA angular (angular) Fixed in 22.0.0-next.12, 21.2.13, 20.3.21, 19.2.22
- Fix · GHSA-rfh7-fxqc-q52v @angular/platform-server (npm) Fixed in 22.0.0-next.12 Advisory →
- Fix · GHSA-rfh7-fxqc-q52v @angular/platform-server (npm) Fixed in 21.2.13 Advisory →
- Fix · GHSA-rfh7-fxqc-q52v @angular/platform-server (npm) Fixed in 20.3.21 Advisory →
- Fix · GHSA-rfh7-fxqc-q52v @angular/platform-server (npm) Fixed in 19.2.22 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Fuse 7 | Affected | No fix planned: Out of support scope |
Not affected: 1 product
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2026-46417
- 2026-10-03 Alias added: GHSA-rfh7-fxqc-q52v
References
Advisory 5
- https://github.com/angular/angular/security/advisories/GHSA-rfh7-fxqc-q52v
- https://nvd.nist.gov/vuln/detail/CVE-2026-46417
- https://access.redhat.com/security/cve/CVE-2026-46417
- https://bugzilla.redhat.com/show_bug.cgi?id=2491444
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-46417.json
More Angular vulnerabilities
- TI-2026-60076 Angular: SSRF and Cross-Origin Credential Disclosure via URL Resolution Discrepancy in SSR CVSS 4.0HIGH 8.6
- TI-2026-60080 Angular: SSR XSS via Unescaped <template> Content Across DocumentFragment Boundaries in Fallback Raw-Content Elements CVSS 4.0HIGH 8.6
- TI-2026-60078 Angular: SSR XSS via Unescaped Processing Instruction (<?...?>) Nodes in Fallback Raw-Content Elements CVSS 4.0HIGH 8.6
- TI-2025-37971 A reflected cross-site scripting (XSS) vulnerability in CKeditor v46.1.0 & Angular… CVSS 3.1MEDIUM 5.4
- TI-2026-36931 Angular: URL Parser Differential in @angular/platform-server leading to SSRF Allowlist Bypass CVSS 4.0HIGH 8.8
- TI-2026-48469 Angular: Cache-Key Ambiguity in HttpTransferCache Leading to Cross-Request Response Reuse and State Poisoning CVSS 4.0HIGH 8.8
Sources
- CVE-2026-46417 · CVE Program
- CVE-2026-46417 · NVD
- FIRST EPSS
- GHSA-rfh7-fxqc-q52v · GitHub Advisory Database · CC BY 4.0
- CVE-2026-46417 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences