Supply chain compromise via malicious package versions (@cap-js/sqlite, @cap-js/postgres, @cap-js/db-service)
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-506.
Summary
The SAP Cloud Application Programming Model is a tool for building enterprise-grade cloud applications, and cap-js/cds-dbs is the monorepo for SQL database services for that tool. On April 29, 2026, compromised versions of `@cap-js/[email protected]`, `@cap-js/[email protected]`, and `@cap-js/[email protected]` were published. The malicious packages harvested credentials and attempted self-propagation. If a compromised version was installed, all credentials accessible on that machine (npm tokens, cloud provider credentials, SSH keys, GitHub PATs) should be considered compromised. User should upgrade to `@cap-js/sqlite` >= 2.4.0, `@cap-js/postgres` >= 2.3.0, `@cap-js/db-service` >= 2.11.0. If a compromised version was ever installed, rotate all affected credentials. No known workarounds are available.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| cap-js | @cap-js/sqlite | = 2.2.2 | — | No fix listed | CNA |
| cap-js | @cap-js/postgres | = 2.2.2 | — | No fix listed | CNA |
| @cap-js/db-service | @cap-js/db-service | = 2.10.1 | — | No fix listed | CNA |
| — | @cap-js/sqlite (npm) | 2.2.2 to before 2.3.0 | 2.3.0 | Patch available | GHSA-pvw4-cvr4-97p8 |
| — | @cap-js/postgres (npm) | 2.2.2 to before 2.3.0 | 2.3.0 | Patch available | GHSA-pvw4-cvr4-97p8 |
| — | @cap-js/db-service (npm) | 2.10.1 to before 2.11.0 | 2.11.0 | Patch available | GHSA-pvw4-cvr4-97p8 |
- @cap-js/sqlite Vendorcap-js Affected = 2.2.2 Fixed in — No fix listed CNA
- @cap-js/postgres Vendorcap-js Affected = 2.2.2 Fixed in — No fix listed CNA
- @cap-js/db-service Vendor@cap-js/db-service Affected = 2.10.1 Fixed in — No fix listed CNA
- @cap-js/sqlite (npm) Vendor— Affected 2.2.2 to before 2.3.0 Fixed in 2.3.0 Patch available GHSA-pvw4-cvr4-97p8
- @cap-js/postgres (npm) Vendor— Affected 2.2.2 to before 2.3.0 Fixed in 2.3.0 Patch available GHSA-pvw4-cvr4-97p8
- @cap-js/db-service (npm) Vendor— Affected 2.10.1 to before 2.11.0 Fixed in 2.11.0 Patch available GHSA-pvw4-cvr4-97p8
Remediation
- Fix · GHSA-pvw4-cvr4-97p8 @cap-js/sqlite (npm) Fixed in 2.3.0 Advisory →
- Fix · GHSA-pvw4-cvr4-97p8 @cap-js/postgres (npm) Fixed in 2.3.0 Advisory →
- Fix · GHSA-pvw4-cvr4-97p8 @cap-js/db-service (npm) Fixed in 2.11.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-46421
- 2026-10-03 Alias added: GHSA-pvw4-cvr4-97p8
References
Sources
- CVE-2026-46421 · CVE Program
- CVE-2026-46421 · NVD
- FIRST EPSS
- GHSA-pvw4-cvr4-97p8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences