Fediverse Embeds: Public-nonce SSRF via ftf_get_site_info AJAX action
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-918 and the CVSS impact.
Summary
Fediverse Embeds embeds fediverse posts on WordPress sites. Prior to version 1.5.9, Fediverse Embeds registered the unauthenticated AJAX action wp_ajax_nopriv_ftf_get_site_info (includes/Site_Info.php) that verified a nonce ftf-fediverse-embeds-nonce and then called file_get_html($site_url) on the attacker-supplied URL. The same nonce was enqueued onto every public page containing a fediverse embed (via includes/Enqueue_Assets.php lines 41-46 + includes/Helpers.php lines 64-83), so the nonce gate was not an authentication boundary; any visitor of a public post with an embed could grab it and reuse it. This issue has been patched in version 1.5.9.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| stefanbohacek | fediverse-embeds-wordpress-plugin | before 1.5.9 | 1.5.9 | Patch available | CNA |
- fediverse-embeds-wordpress-plugin Vendorstefanbohacek Affected before 1.5.9 Fixed in 1.5.9 Patch available CNA
Remediation
- Fix · CNA fediverse-embeds-wordpress-plugin (stefanbohacek) Fixed in 1.5.9
Timeline
- 2026-10-02 Threatist record created from CVE-2026-46698
References
More stefanbohacek vulnerabilities
- TI-2024-35147 WordPress Fediverse Embeds plugin <= 1.5.3 - Arbitrary File Upload vulnerability CVSS 3.1CRITICAL 10.0
- TI-2026-34326 Fediverse Embeds: Unauthenticated SSRF / open proxy via REST media-proxy endpoint CVSS 3.1HIGH 7.5
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences