Notepad++: Privilege Escalation in the Installer via Uncontrolled Executable Search Path
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-426.
Summary
Notepad++ is a free and open-source source code editor. From 8.9.4 until 8.9.6, Notepad++ contains a local privilege escalation vulnerability in the installer. During installation, the installer invokes powershell.exe without using an absolute path after setting the working directory to the installation contextMenu directory. If an attacker can pre-place a malicious powershell.exe in a user-writable custom installation directory, and a privileged user later runs the installer and selects that directory, the attacker-controlled executable is launched with the elevated privileges of the installer. This vulnerability is fixed in 8.9.6.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| notepad-plus-plus | notepad-plus-plus | 8.9.4 to before 8.9.6 | 8.9.6 | Patch available | CNA |
- notepad-plus-plus Vendornotepad-plus-plus Affected 8.9.4 to before 8.9.6 Fixed in 8.9.6 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:notepad-plus-plus:notepad\+\+:*:*:*:*:*:*:*:* | 8.9.4 to before 8.9.6 | Vulnerable | notepad-plus-plus |
- cpe:2.3:a:notepad-plus-plus:notepad\+\+:*:*:*:*:*:*:*:* Versions 8.9.4 to before 8.9.6 Vulnerable ·notepad-plus-plus
Remediation
- Fix · CNA notepad-plus-plus (notepad-plus-plus) Fixed in 8.9.6
Timeline
- 2026-10-02 Threatist record created from CVE-2026-46710
References
More notepad-plus-plus Notepad++ vulnerabilities
- TI-2025-14195 Notepad++ < 8.8.9 WinGUp Updater Lacks Update Integrity Verification KEVCVSS 4.0HIGH 7.7
- TI-2026-36070 Notepad++: Arbitrary Code Execution via shortcuts.xml UserCommand Injection CVSS 3.1HIGH 7.8
- TI-2026-36048 Notepad++: Arbitrary Code Execution via config.xml commandLineInterpreter CVSS 3.1HIGH 7.8
- TI-2026-04836 Stack-Based Buffer Overflow in Notepad++ File Drop Handler leads to DoS CVSS 3.1HIGH 7.8
- TI-2023-20921 Notepad++ vulnerable to heap buffer write overflow in Utf8_16_Read::convert CVSS 3.1HIGH 7.8
- TI-2026-37981 Notepad++ TOCTOU: HMAC Checks Disk, Executes from Memory CVSS 4.0HIGH 7.5
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences