VMware Avi Load Balancer Remote Code Execution Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-94.
Summary
VMware Avi Load Balancer contains a remote code execution vulnerability. A malicious user with network access may be able to access the Avi Control plane and execute code remotely. Affected versions: 32.1.1 (fixed in 32.1.2) 31.1.1 through 31.2.2 (fixed in 31.2.2-2p3) 30.1.1 through 30.2.6 (fixed in 30.2.7) 22.1.1 through 22.1.7 (fixed in 30.2.7)
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| VMware | Avi Load Balancer | 32.1.1; 31.1.1 – 31.2.2; 30.1.1 – 30.2.6; 22.1.1 – 22.1.7 | — | No fix listed | CNA |
- Avi Load Balancer VendorVMware Affected 32.1.1; 31.1.1 – 31.2.2; 30.1.1 – 30.2.6; 22.1.1 – 22.1.7 Fixed in — No fix listed CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:broadcom:vmware_avi_load_balancer:*:*:*:*:*:*:*:* | 22.1.1 – 22.1.7; 30.1.1 to before 30.2.7; 31.1.1 to before 31.2.2 | Vulnerable | Broadcom |
| cpe:2.3:a:broadcom:vmware_avi_load_balancer:31.2.2:-:*:*:*:*:*:* | 31.2.2 | Vulnerable | Broadcom |
| cpe:2.3:a:broadcom:vmware_avi_load_balancer:31.2.2:2p1:*:*:*:*:*:* | 31.2.2 2p1 | Vulnerable | Broadcom |
| cpe:2.3:a:broadcom:vmware_avi_load_balancer:31.2.2:2p2:*:*:*:*:*:* | 31.2.2 2p2 | Vulnerable | Broadcom |
| cpe:2.3:a:broadcom:vmware_avi_load_balancer:32.1.1:*:*:*:*:*:*:* | 32.1.1 | Vulnerable | Broadcom |
- cpe:2.3:a:broadcom:vmware_avi_load_balancer:*:*:*:*:*:*:*:* Versions 22.1.1 – 22.1.7; 30.1.1 to before 30.2.7; 31.1.1 to before 31.2.2 Vulnerable ·Broadcom
- cpe:2.3:a:broadcom:vmware_avi_load_balancer:31.2.2:-:*:*:*:*:*:* Versions 31.2.2 Vulnerable ·Broadcom
- cpe:2.3:a:broadcom:vmware_avi_load_balancer:31.2.2:2p1:*:*:*:*:*:* Versions 31.2.2 2p1 Vulnerable ·Broadcom
- cpe:2.3:a:broadcom:vmware_avi_load_balancer:31.2.2:2p2:*:*:*:*:*:* Versions 31.2.2 2p2 Vulnerable ·Broadcom
- cpe:2.3:a:broadcom:vmware_avi_load_balancer:32.1.1:*:*:*:*:*:*:* Versions 32.1.1 Vulnerable ·Broadcom
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-47867
- 2026-10-03 Alias added: GHSA-cf92-7pc6-48mm
References
More VMware vulnerabilities
- TI-2026-42442 vCenter directory-traversal vulnerability KEVCVSS 3.1CRITICAL 9.8
- TI-2024-26040 Privilege escalation in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2024-26039 Heap-overflow in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2024-24610 Out-of-bounds write in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2023-16914 VMware vCenter Server Out-of-Bounds Write Vulnerability KEVCVSS 3.1CRITICAL 9.8
- TI-2023-07303 Command injection in Aria Operations for Networks KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-47867 · CVE Program
- CVE-2026-47867 · NVD
- FIRST EPSS
- GHSA-cf92-7pc6-48mm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences