PHP Standard Library: HTTP/2 server-side missing content-length validation enables request smuggling
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
PHP Standard Library (PSL) is set of APIs covering async, collections, networking, I/O, cryptography, terminal UI, etc. In versions 6.1.0, 6.1.1 and 6.2.0, the Psl\H2\ServerConnection does not validate that the total bytes received in DATA frames match the content-length header declared in the HEADERS frame, allowing request smuggling. This is in violation of RFC 9113 §8.1.1. A malicious client is able to send more DATA bytes than declared, smuggling additional content past application-level size limits and send fewer DATA bytes than declared and close the stream early, causing applications that trust the declared length to behave incorrectly. The vulnerability is only reachable for consumers using Psl\H2\ServerConnection directly to accept untrusted client traffic. Consumers of documented high-level PSL APIs are not affected. This issue has been fixed in versions 6.1.2 and 6.2.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| php-standard-library | php-standard-library | 6.1.0 to before 6.1.2; 6.2.0 to before 6.2.1 | 6.1.2, 6.2.1 | Patch available | CNA |
| php-standard-library | php-standard-library/h2 | 6.1.0 to before 6.1.2; 6.2.0 to before 6.2.1 | 6.1.2, 6.2.1 | Patch available | CNA |
| — | php-standard-library/h2 (Packagist) | 6.1.0 to before 6.1.2 | 6.1.2 | Patch available | GHSA-pw9p-jvrm-f7rm |
| — | php-standard-library/h2 (Packagist) | 6.2.0 to before 6.2.1 | 6.2.1 | Patch available | GHSA-pw9p-jvrm-f7rm |
| — | php-standard-library/php-standard-library (Packagist) | 6.1.0 to before 6.1.2 | 6.1.2 | Patch available | GHSA-pw9p-jvrm-f7rm |
| — | php-standard-library/php-standard-library (Packagist) | 6.2.0 to before 6.2.1 | 6.2.1 | Patch available | GHSA-pw9p-jvrm-f7rm |
- php-standard-library Vendorphp-standard-library Affected 6.1.0 to before 6.1.2; 6.2.0 to before 6.2.1 Fixed in 6.1.2, 6.2.1 Patch available CNA
- php-standard-library/h2 Vendorphp-standard-library Affected 6.1.0 to before 6.1.2; 6.2.0 to before 6.2.1 Fixed in 6.1.2, 6.2.1 Patch available CNA
- php-standard-library/h2 (Packagist) Vendor— Affected 6.1.0 to before 6.1.2 Fixed in 6.1.2 Patch available GHSA-pw9p-jvrm-f7rm
- php-standard-library/h2 (Packagist) Vendor— Affected 6.2.0 to before 6.2.1 Fixed in 6.2.1 Patch available GHSA-pw9p-jvrm-f7rm
- php-standard-library/php-standard-library (Packagist) Vendor— Affected 6.1.0 to before 6.1.2 Fixed in 6.1.2 Patch available GHSA-pw9p-jvrm-f7rm
- php-standard-library/php-standard-library (Packagist) Vendor— Affected 6.2.0 to before 6.2.1 Fixed in 6.2.1 Patch available GHSA-pw9p-jvrm-f7rm
Remediation
- Fix · CNA php-standard-library (php-standard-library) Fixed in 6.1.2, 6.2.1
- Fix · CNA php-standard-library/h2 (php-standard-library) Fixed in 6.1.2, 6.2.1
- Fix · GHSA-pw9p-jvrm-f7rm php-standard-library/h2 (Packagist) Fixed in 6.1.2 Advisory →
- Fix · GHSA-pw9p-jvrm-f7rm php-standard-library/h2 (Packagist) Fixed in 6.2.1 Advisory →
- Fix · GHSA-pw9p-jvrm-f7rm php-standard-library/php-standard-library (Packagist) Fixed in 6.1.2 Advisory →
- Fix · GHSA-pw9p-jvrm-f7rm php-standard-library/php-standard-library (Packagist) Fixed in 6.2.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-48979
- 2026-10-03 Alias added: GHSA-pw9p-jvrm-f7rm
References
Other 4
- https://github.com/php-standard-library/php-standard-library/security/advisories/GHSA-pw9p-jvrm-f7rm
- https://github.com/php-standard-library/php-standard-library/releases/tag/6.1.2
- https://github.com/php-standard-library/php-standard-library/releases/tag/6.2.1
- https://github.com/php-standard-library/php-standard-library
Sources
- CVE-2026-48979 · CVE Program
- CVE-2026-48979 · NVD
- FIRST EPSS
- GHSA-pw9p-jvrm-f7rm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences