DataEase: Authenticated Stored XSS in DataEase Template Static Resources
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
DataEase is an open source data visualization and analysis tool. Prior to 2.10.23, DataEase template static resources let authenticated users submit TemplateManageRequest.staticResource through POST /de2api/templateManage/save or DataVisualizationServer.decompression, after which StaticResourceServer.saveFilesToServe and StaticResourceServer.saveSingleFileToServe write Base64-decoded .svg content to /de2api/static-resource/<name>.svg without validating extension, MIME type, decoded bytes, or SVG scriptability, causing stored same-origin cross-site scripting when a victim loads the resource. This issue is fixed in version 2.10.23.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA dataease (dataease) Fixed in 2.10.23
Timeline
- 2026-10-02 Threatist record created from CVE-2026-49867
References
More dataease vulnerabilities
- TI-2024-38037 An issue in DataEase v1 allows an attacker to execute arbitrary code via the user account and password components. CVSS 3.1CRITICAL 9.8
- TI-2023-12981 SQL injection vulnerability due to the keyword blacklist for defending against SQL injection will be bypassed CVSS 3.1CRITICAL 9.8
- TI-2022-18688 Dataease Mysql Data Source JDBC Connection Parameters Not Verified Leads to Deserialization Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2026-24677 Dataease: Redshift JDBC RCE Bypass CVSS 4.0CRITICAL 9.3
- TI-2026-24674 DataEase SQL Injection Vulnerability CVSS 4.0CRITICAL 9.3
- TI-2024-37398 DataEase has an unauthorized vulnerability CVSS 4.0CRITICAL 9.3
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences